Bug 972460 - RFE: Rebase Open vSwitch to include in-tree tunneling support
RFE: Rebase Open vSwitch to include in-tree tunneling support
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openvswitch (Show other bugs)
3.0
Unspecified Unspecified
urgent Severity urgent
: Upstream M3
: 4.0
Assigned To: Thomas Graf
Ofer Blaut
: FutureFeature, Rebase
Depends On: 976810 981285 989522 992917 1002430 1009006
Blocks: RHOS40RFE 1002783 1011976 1011979
  Show dependency treegraph
 
Reported: 2013-06-09 11:12 EDT by Perry Myers
Modified: 2018-02-08 05:05 EST (History)
16 users (show)

See Also:
Fixed In Version: openvswitch-1.11.0-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Rebase package(s) to version: 1.11 Highlights, important fixes, or notable enhancements: - Flow based tunneling to support VXLAN and GRE encapsulation - OpenFlow: * The "dec_mpls_ttl" and "set_mpls_ttl" actions from OpenFlow 1.1 and later are now implemented. * New "stack" extension for use in actions, to push and pop from NXM fields. * The "load" and "set_field" actions can now modify the "in_port". (This allows one to enable output to a flow's input port by setting the in_port to some unused value, such as OFPP_NONE.)
Story Points: ---
Clone Of:
: 976810 1002430 1002783 1011976 1011979 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:05:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2013-06-09 11:12:22 EDT
Description of problem:
openvswitch upstream (not in the kernel) implements port based tunneling, and the ovs userspace commands utilize this port based tunneling directly.

port based tunneling from openvswitch will likely not make it into the core kernel.  Instead, the kernel implements flow based tunneling (outside of the openvswitch kmod).

There are two main requirements:
* Quantum openvswitch plugin needs to be able to use tunneling
* Other 3rd party plugins that rely on openvswitch need to be able to use tunneling

Since port based tunneling will not be in RHEL (or RHOS), this means that we can either:

* Fix every Quantum plugin that relies on openvswitch (individually) to use direct calls to the ip binary to create flow based tunnels
or
* Fix openvswitch userspace a single time to have it create flow based tunnels

As a short term hack, it would certainly be possible to just fix the quantum openvswitch plugin, but that would leave all 3rd party plugin vendors with the same problem and needing to implement this as well

So the best solution would be for us to fix openvswitch userspace to utilize flow based tunneling directly

This bug, therefore, becomes a blocker for RHOS Networking to be able to utilize tunneling for Quantum networks
Comment 2 Thomas Graf 2013-06-21 09:47:49 EDT
Support for in-tree tunneling implementation is being merged into upstream kernels and support for these changes on the user space side is likely to land in the OVS 1.12 release if not the 1.11 release.

Rebasing to the release will enable the Quantum plugin to use tunneling in RHEL based kernels through both OpenFlow and the ovs-vsctl add-port CLI interface.
Comment 3 Bob Kukura 2013-06-25 13:58:29 EDT
Thomas, will the OVS user space version that supports tunneling (as used by quantum-openvswitch-agent) also require a new kernel with corresponding OVS changes?
Comment 4 Thomas Graf 2013-06-25 15:15:24 EDT
(In reply to Bob Kukura from comment #3)
> Thomas, will the OVS user space version that supports tunneling (as used by
> quantum-openvswitch-agent) also require a new kernel with corresponding OVS
> changes?

Yes, it will require an update to the tunneling implementation and the addition of a new port type for tunnels. This is being tracked in BZ976810
Comment 5 Thomas Graf 2013-07-29 07:39:08 EDT
We have verified that the current 1.11 git branch out of which the 1.11 release will be based on is sufficient to support GRE tunneling from a user space POV.
Comment 14 Ofer Blaut 2013-10-20 10:03:45 EDT
GRE was tested according to test plan - seems ok
Comment 17 errata-xmlrpc 2013-12-19 19:05:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.