Bug 973855 - [abrt] menu-cache-0.4.1-2.fc19: g_realloc: Process /usr/libexec/menu-cached was killed by signal 11 (SIGSEGV)
[abrt] menu-cache-0.4.1-2.fc19: g_realloc: Process /usr/libexec/menu-cached w...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: menu-cache (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:0ddfc5940e93e0fe1c8591883c0...
:
: 968873 980909 981599 1000756 1018508 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 22:03 EDT by Chris
Modified: 2013-12-10 01:56 EST (History)
11 users (show)

See Also:
Fixed In Version: lxpanel-0.6.1-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-10 01:56:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (29.25 KB, text/plain)
2013-06-12 22:03 EDT, Chris
no flags Details
File: cgroup (140 bytes, text/plain)
2013-06-12 22:03 EDT, Chris
no flags Details
File: core_backtrace (1.77 KB, text/plain)
2013-06-12 22:03 EDT, Chris
no flags Details
File: dso_list (267 bytes, text/plain)
2013-06-12 22:03 EDT, Chris
no flags Details
File: environ (953 bytes, text/plain)
2013-06-12 22:03 EDT, Chris
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-12 22:03 EDT, Chris
no flags Details
File: maps (12.99 KB, text/plain)
2013-06-12 22:03 EDT, Chris
no flags Details
File: open_fds (1.87 KB, text/plain)
2013-06-12 22:03 EDT, Chris
no flags Details
File: proc_pid_status (934 bytes, text/plain)
2013-06-12 22:03 EDT, Chris
no flags Details
File: var_log_messages (418 bytes, text/plain)
2013-06-12 22:03 EDT, Chris
no flags Details

  None (edit)
Description Chris 2013-06-12 22:03:11 EDT
Version-Release number of selected component:
menu-cache-0.4.1-2.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/libexec/menu-cached
crash_function: g_realloc
executable:     /usr/libexec/menu-cached
kernel:         3.9.4-301.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (7 frames)
 #4 g_realloc at gmem.c:224
 #5 g_string_maybe_expand at gstring.c:107
 #6 g_string_set_size at gstring.c:400
 #7 g_io_channel_fill_buffer at giochannel.c:1504
 #8 g_io_channel_read_chars at giochannel.c:2055
 #9 ik_read_events at inotify-kernel.c:442
 #10 ik_read_callback at inotify-kernel.c:455
Comment 1 Chris 2013-06-12 22:03:16 EDT
Created attachment 760371 [details]
File: backtrace
Comment 2 Chris 2013-06-12 22:03:19 EDT
Created attachment 760372 [details]
File: cgroup
Comment 3 Chris 2013-06-12 22:03:21 EDT
Created attachment 760373 [details]
File: core_backtrace
Comment 4 Chris 2013-06-12 22:03:24 EDT
Created attachment 760374 [details]
File: dso_list
Comment 5 Chris 2013-06-12 22:03:26 EDT
Created attachment 760375 [details]
File: environ
Comment 6 Chris 2013-06-12 22:03:29 EDT
Created attachment 760376 [details]
File: limits
Comment 7 Chris 2013-06-12 22:03:31 EDT
Created attachment 760377 [details]
File: maps
Comment 8 Chris 2013-06-12 22:03:34 EDT
Created attachment 760378 [details]
File: open_fds
Comment 9 Chris 2013-06-12 22:03:36 EDT
Created attachment 760379 [details]
File: proc_pid_status
Comment 10 Chris 2013-06-12 22:03:39 EDT
Created attachment 760380 [details]
File: var_log_messages
Comment 11 Christoph Wickert 2013-06-30 12:30:17 EDT
*** Bug 968873 has been marked as a duplicate of this bug. ***
Comment 12 Andre Vehreschild 2013-07-09 11:31:27 EDT
I checked the default applications and on quitting the program (w/o any modifications) the crash occured.

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/libexec/menu-cached
crash_function: g_malloc
executable:     /usr/libexec/menu-cached
kernel:         3.9.9-301.fc19.x86_64
package:        menu-cache-0.4.1-2.fc19
reason:         Process /usr/libexec/menu-cached was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
Comment 13 Robert Kief 2013-07-28 19:49:59 EDT
I was using the MATE Control Center and had just finished setting up the screen saver when the error popup appeared.  This is a new Fedora 19 install.  MATE, KDE, LXDE,and Xfce were installed today.  I used GNOME as the default installed desktop.

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/libexec/menu-cached
crash_function: g_malloc
executable:     /usr/libexec/menu-cached
kernel:         3.10.3-300.fc19.x86_64
package:        menu-cache-0.4.1-2.fc19
reason:         Process /usr/libexec/menu-cached was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
Comment 14 Christoph Wickert 2013-07-31 09:37:41 EDT
*** Bug 980909 has been marked as a duplicate of this bug. ***
Comment 15 Christoph Wickert 2013-07-31 09:37:54 EDT
*** Bug 981599 has been marked as a duplicate of this bug. ***
Comment 16 Jan Pokorný 2013-11-07 16:01:33 EST
Tried F20 LXDE Beta and observed this as per [bug 980909] marked as
a duplicate of this one.

PCManFM attempt to load "menu://applications/Accessories" never finished
and this appeared in the messages/journal:

> Nov 07 21:37:07 localhost.localdomain kernel: menu-cached[1091]:
>   segfault at 100000007 ip 00007fe16acfd3ea sp 00007fffc91ef2c0
>   error 4 in libc-2.18.so[7fe16ac81000+1b4000]

# rpm -q menu-cache pcmanfm
> menu-cache-0.4.1-3.fc20.x86_64
> pcmanfm-1.1.2-2.D20130830gitfc8adaab77.fc20.x86_64
Comment 17 Christoph Wickert 2013-11-14 09:27:24 EST
*** Bug 1000756 has been marked as a duplicate of this bug. ***
Comment 18 Christoph Wickert 2013-11-14 09:27:37 EST
*** Bug 1018508 has been marked as a duplicate of this bug. ***
Comment 19 Fedora Update System 2013-11-15 18:03:20 EST
lxpanel-0.6.1-1.fc20,lxlauncher-0.2.2-4.fc20,pcmanfm-1.1.2-3.D20130830gitfc8adaab77.fc20,libfm-1.1.2.2-3.fc20,menu-cache-0.5.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/lxpanel-0.6.1-1.fc20,lxlauncher-0.2.2-4.fc20,pcmanfm-1.1.2-3.D20130830gitfc8adaab77.fc20,libfm-1.1.2.2-3.fc20,menu-cache-0.5.1-1.fc20
Comment 20 Fedora Update System 2013-11-17 01:59:52 EST
Package lxpanel-0.6.1-1.fc20, lxlauncher-0.2.2-4.fc20, pcmanfm-1.1.2-3.D20130830gitfc8adaab77.fc20, libfm-1.1.2.2-3.fc20, menu-cache-0.5.1-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lxpanel-0.6.1-1.fc20 lxlauncher-0.2.2-4.fc20 pcmanfm-1.1.2-3.D20130830gitfc8adaab77.fc20 libfm-1.1.2.2-3.fc20 menu-cache-0.5.1-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21536/lxpanel-0.6.1-1.fc20,lxlauncher-0.2.2-4.fc20,pcmanfm-1.1.2-3.D20130830gitfc8adaab77.fc20,libfm-1.1.2.2-3.fc20,menu-cache-0.5.1-1.fc20
then log in and leave karma (feedback).
Comment 21 Lukas Slebodnik 2013-12-02 04:33:40 EST
I just log in to lxde.


reporter:       libreport-2.1.9
backtrace_rating: 4
cmdline:        /usr/libexec/menu-cached
crash_function: g_realloc
executable:     /usr/libexec/menu-cached
kernel:         3.11.8-200.fc19.x86_64
package:        menu-cache-0.4.1-2.fc19
reason:         Process /usr/libexec/menu-cached was killed by signal 11 (SIGSEGV)
runlevel:       N 3
type:           CCpp
uid:            1000
Comment 22 Fedora Update System 2013-12-10 01:56:08 EST
lxpanel-0.6.1-3.fc20, lxlauncher-0.2.2-4.fc20, pcmanfm-1.1.2-3.D20130830gitfc8adaab77.fc20, libfm-1.1.2.2-3.fc20, menu-cache-0.5.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.