Bug 974130 - /usr/lib/debug/ needs also bin/lib/lib64 symlinks
/usr/lib/debug/ needs also bin/lib/lib64 symlinks
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: filesystem (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 980536
  Show dependency treegraph
 
Reported: 2013-06-13 09:36 EDT by Jan Kratochvil
Modified: 2013-07-15 21:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: filesystem-3.2-13.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 980536 (view as bug list)
Environment:
Last Closed: 2013-07-15 21:45:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2013-06-13 09:36:25 EDT
Description of problem:
Since the /bin etc. symlinks debuginfos stopped working unless one uses them via build-id.

There should be:
/usr/lib/debug/bin -> usr/bin
/usr/lib/debug/lib -> usr/lib
/usr/lib/debug/lib64 -> usr/lib64
/usr/lib/debug/sbin -> usr/sbin

Version-Release number of selected component (if applicable):
F-17 upwards.

How reproducible:
Always.

Steps to Reproduce:
yum install keyutils
debuginfo-install keyutils
mv /usr/lib/debug/.build-id /usr/lib/debug/.build-id-x
gdb keyctl

Actual results:
Reading symbols from /usr/bin/keyctl...Reading symbols from /usr/bin/keyctl...(no debugging symbols found)...done.
(no debugging symbols found)...done.

Expected results:
Reading symbols from /usr/bin/keyctl...
warning: the debug information found in "/usr/lib/debug//usr/bin/keyctl.debug" does not match "/usr/bin/keyctl" (CRC mismatch).

Additional info:
The warning is a different bug (tracked as Bug 971119); that is caused by dwz.

There exists:
/usr/lib/debug/bin/keyctl.debug

But GDB cannot find that, GDB found /usr/bin/keyctl and also its canonical name is /usr/bin/keyctl.

It probably should have some %pre/%post script to move existing debuginfos into the common subdirectories before creating the symlink.
Comment 1 Ondrej Vasik 2013-06-13 16:30:33 EDT
Thanks for report. I'll fix that in next filesystem build
Comment 4 Fedora Update System 2013-06-21 09:03:04 EDT
filesystem-3.2-12.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/filesystem-3.2-12.fc19
Comment 5 Fedora Update System 2013-06-21 15:17:18 EDT
Package filesystem-3.2-12.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing filesystem-3.2-12.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11452/filesystem-3.2-12.fc19
then log in and leave karma (feedback).
Comment 6 Jan Kratochvil 2013-06-25 04:46:00 EDT
I have found a problem, we need also:
ln -s ../.dwz /usr/lib/debug/usr/.dwz

reproducer:

$ gdb dbus-send
Reading symbols from /usr/bin/dbus-send...Reading symbols from /usr/lib/debug/usr/bin/dbus-send.debug...could not read '/usr/lib/debug/usr/bin/../.dwz/dbus-1.6.12-1.fc18.x86_64': No such file or directory

dbus-1.6.12-1.fc18.x86_64
dbus-debuginfo-1.6.12-1.fc18.x86_64


Another problem may be that rpm -V *-debuginfo starts to complain then:
$ rpm -V dbus-debuginfo
....L....    /usr/lib/debug/bin
....L....    /usr/lib/debug/lib64
But that may be rather reassigned to rpm maintainers.
Comment 7 Fedora Update System 2013-07-01 20:33:08 EDT
filesystem-3.2-12.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Jan Kratochvil 2013-07-02 02:20:40 EDT
This issue is not closed.

Either .dwz symlink should be added or - as discussed this update should be reverted for F-19 and present only for F-20+.
Comment 9 Fedora Update System 2013-07-08 08:18:08 EDT
filesystem-3.2-13.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/filesystem-3.2-13.fc19
Comment 10 Fedora Update System 2013-07-08 21:30:11 EDT
Package filesystem-3.2-13.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing filesystem-3.2-13.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12588/filesystem-3.2-13.fc19
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-07-15 21:45:26 EDT
filesystem-3.2-13.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.