Bug 980536 - /usr/lib/debug/ needs also bin/lib/lib64 symlinks
/usr/lib/debug/ needs also bin/lib/lib64 symlinks
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: filesystem (Show other bugs)
7.0
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Ondrej Vasik
Jan Ščotka
: Reopened
Depends On: 974130
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 12:05 EDT by Jan Kratochvil
Modified: 2014-06-13 06:10 EDT (History)
4 users (show)

See Also:
Fixed In Version: filesystem-3.2-13.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 974130
Environment:
Last Closed: 2014-06-13 06:10:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2013-07-02 12:05:18 EDT
Tracker for Fedora Bug:

+++ This bug was initially created as a clone of Bug #974130 +++

Description of problem:
Since the /bin etc. symlinks debuginfos stopped working unless one uses them via build-id.

Steps to Reproduce:
yum install keyutils
debuginfo-install keyutils
mv /usr/lib/debug/.build-id /usr/lib/debug/.build-id-x
gdb keyctl

Actual results:
Reading symbols from /usr/bin/keyctl...Reading symbols from /usr/bin/keyctl...(no debugging symbols found)...done.
(no debugging symbols found)...done.

Expected results:
Reading symbols from /usr/bin/keyctl...
warning: the debug information found in "/usr/lib/debug//usr/bin/keyctl.debug" does not match "/usr/bin/keyctl" (CRC mismatch).

Additional info:
The warning is a different bug (tracked as Bug 971119); that is caused by dwz.

--- Additional comment from Jan Kratochvil on 2013-07-02 08:20:40 CEST ---

This issue is not closed.

[...] .dwz symlink should be added [...]
Comment 1 Ondrej Vasik 2013-07-08 06:36:32 EDT
Commited to distgit -> http://bulk-mail.corp.redhat.com/archives/cvs-commits-list/2013-July/msg01679.html -> MODIFIED .
Comment 3 Jan Kratochvil 2014-01-23 10:13:38 EST
Works for me.

                         HOSTNAME=ibm-x3250m4-13.rhts.eng.bos.redhat.com
                            JOBID=581507
                         RECIPEID=1205770
                    RESULT_SERVER=127.0.0.1:7081
                           DISTRO=RHEL-7.0-20140123.n.0
                     ARCHITECTURE=x86_64

# yum install /usr/bin/debuginfo-install
# debuginfo-install keyutils
# mv /usr/lib/debug/.build-id /usr/lib/debug/.build-id-x
# gdb keyctl
GNU gdb (GDB) Red Hat Enterprise Linux 7.6.1-48.el7
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/keyctl...Reading symbols from /usr/lib/debug/usr/bin/keyctl.debug...done.
done.
(gdb) q

I have verified also your tested gdb-7.6.1-46.el7.x86_64 works on this box.
I have returned the machine to beaker now but it should be reprooducible with DISTRO=RHEL-7.0-20140123.n.0 I think.
Comment 10 Ludek Smid 2014-06-13 06:10:34 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.