Bug 974236 - Remove Sample Configuration File topics, add references to Configuration Reference Guide
Remove Sample Configuration File topics, add references to Configuration Refe...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Installation_and_Configuration_Guide (Show other bugs)
3.0
Unspecified Unspecified
medium Severity medium
: ---
: 4.0
Assigned To: Summer Long
ecs-bugs
: Documentation, Triaged
: 974792 (view as bug list)
Depends On:
Blocks: 1011085
  Show dependency treegraph
 
Reported: 2013-06-13 14:37 EDT by Stephen Gordon
Modified: 2014-01-06 17:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-06 17:08:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2013-06-13 14:37:56 EDT
The ICG contains a number of sample configuration files as appendices. In many cases the upstream git project for each component also contains sample configuration files. To make future maintenance easier it would be desirable to automate generation of the appendices from the upstream git repositories.

I believe some work to achieve this may already be occurring in the openstack-manuals project but either way the process should be relatively simple. We would probably need to maintain a mapping like:

topicid,project,file
Comment 1 Stephen Gordon 2013-09-24 14:42:18 EDT
This content will now appear in the Configuration Reference Guide.
Comment 3 Summer Long 2013-11-17 22:19:07 EST
Added new topic 'Additional Documentation' - 25104, and added into the Installation Guide spec.
Comment 4 Summer Long 2013-11-19 21:10:16 EST
Review and reworks have been done, and merged. Ready for QA when new packages for CRG and ICG have been posted.
Comment 5 Summer Long 2013-11-21 02:09:53 EST
*** Bug 974792 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.