Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 975159 - UnicodeDecodeError: 'ascii' codec can't decode byte 0xc4 in position 0: ordinal not in range(128)
Summary: UnicodeDecodeError: 'ascii' codec can't decode byte 0xc4 in position 0: ordin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Kolman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9080b197631b0d94ef398cceddb...
Depends On:
Blocks: F19Blocker, F19FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2013-06-17 18:03 UTC by Kamil Páral
Modified: 2013-06-22 02:30 UTC (History)
13 users (show)

Fixed In Version: anaconda-19.30.9-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-22 02:30:42 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (258.73 KB, text/plain)
2013-06-17 18:03 UTC, Kamil Páral
no flags Details
File: anaconda.log (4.06 KB, text/plain)
2013-06-17 18:03 UTC, Kamil Páral
no flags Details
File: backtrace (1.32 KB, text/plain)
2013-06-17 18:03 UTC, Kamil Páral
no flags Details
File: environ (518 bytes, text/plain)
2013-06-17 18:03 UTC, Kamil Páral
no flags Details
File: ifcfg.log (486 bytes, text/plain)
2013-06-17 18:03 UTC, Kamil Páral
no flags Details
File: lsblk_output (2.23 KB, text/plain)
2013-06-17 18:03 UTC, Kamil Páral
no flags Details
File: messages (131.24 KB, text/plain)
2013-06-17 18:03 UTC, Kamil Páral
no flags Details
File: nmcli_dev_list (3.36 KB, text/plain)
2013-06-17 18:03 UTC, Kamil Páral
no flags Details
File: program.log (36.16 KB, text/plain)
2013-06-17 18:03 UTC, Kamil Páral
no flags Details
File: storage.log (141.26 KB, text/plain)
2013-06-17 18:03 UTC, Kamil Páral
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 975193 0 unspecified CLOSED geolocation works haphazardly 2021-02-22 00:41:40 UTC

Internal Links: 975193

Description Kamil Páral 2013-06-17 18:03:10 UTC
Description of problem:
I just booted F19 TC3 Live and hit Continue in Czech language (autoselected).
The following was filed automatically by anaconda:
anaconda 19.30.5-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/datetime_spoke.py", line 396, in status
    return _("%s timezone") % self.data.timezone.timezone
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 252, in _updateCompleteness
    spoke.selector.set_property("status", spoke.status)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 208, in _createBox
    self._updateCompleteness(spoke)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 353, in refresh
    self._createBox()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 479, in _on_continue_clicked
    nextAction.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 68, in _on_continue_clicked
    cb()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 356, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 72, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc4 in position 0: ordinal not in range(128)

Version-Release number of selected component:
anaconda-19.30.5-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-TC rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.4-301.fc19.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 72, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 356, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 68, in _on_continue_clicked
    cb()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 479, in _on_continue_clicked
    nextAction.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 353, in refresh
    self._createBox()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 208, in _createBox
    self._updateCompleteness(spoke)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 252, in _updateCompleteness
    spoke.selector.set_property("status", spoke.status)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/datetime_spoke.py", line 396, in status
    return _("%s timezone") % self.data.timezone.timezone
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc4 in position 0: ordinal not in range(128)

Potential duplicate: bug 887236

Comment 1 Kamil Páral 2013-06-17 18:03:17 UTC
Created attachment 762110 [details]
File: anaconda-tb

Comment 2 Kamil Páral 2013-06-17 18:03:24 UTC
Created attachment 762111 [details]
File: anaconda.log

Comment 3 Kamil Páral 2013-06-17 18:03:29 UTC
Created attachment 762112 [details]
File: backtrace

Comment 4 Kamil Páral 2013-06-17 18:03:33 UTC
Created attachment 762114 [details]
File: environ

Comment 5 Kamil Páral 2013-06-17 18:03:37 UTC
Created attachment 762115 [details]
File: ifcfg.log

Comment 6 Kamil Páral 2013-06-17 18:03:41 UTC
Created attachment 762116 [details]
File: lsblk_output

Comment 7 Kamil Páral 2013-06-17 18:03:45 UTC
Created attachment 762117 [details]
File: messages

Comment 8 Kamil Páral 2013-06-17 18:03:49 UTC
Created attachment 762118 [details]
File: nmcli_dev_list

Comment 9 Kamil Páral 2013-06-17 18:03:54 UTC
Created attachment 762119 [details]
File: program.log

Comment 10 Kamil Páral 2013-06-17 18:03:58 UTC
Created attachment 762120 [details]
File: storage.log

Comment 11 Kamil Páral 2013-06-17 18:19:06 UTC
I can reproduce this 100% *provided that* Czech language is pre-selected for me. It crashes after I "accept my faith". However, Anaconda sometimes pre-selects Czech and sometimes English and I'm completely unaware of the conditions. Maybe it's another bug?

English pre-selected -> OK
English pre-selected and Czech selected manually -> OK
Czech pre-selected -> CRASH

Proposing as a blocker:
"The installer must run when launched normally from the release-blocking images."
http://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria

Comment 12 Kamil Páral 2013-06-17 18:23:28 UTC
I have just booted TC3 DVD with Czech pre-selected and it does not crash. It concerns only Live media then.

Comment 13 Kamil Páral 2013-06-17 18:47:44 UTC
Reproducer:

1. Connect from a network that is detected as in Czech Republic (that is not Red Hat's Brno office, by the way).
2. Boot Live and run Anaconda
3. If English is pre-selected, quit Anaconda and run it again. Czech should be pre-selected now.
4. Hit Continue -> Accept -> CRASH

Comment 14 Kamil Páral 2013-06-17 18:57:34 UTC
(In reply to Kamil Páral from comment #11)
> However, Anaconda sometimes
> pre-selects Czech and sometimes English and I'm completely unaware of the
> conditions. Maybe it's another bug?

I reported the geolocation issues as bug 975193.

Comment 15 Parag Nemade 2013-06-18 08:34:54 UTC
Downloaded Gnome Live F19 Final TC5 image
Tried to install using virt-manager
Selected "Marathi" language in Anaconda
and this exception occurred

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-TC rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
package:        anaconda-19.30.8-1.fc19.x86_64
packaging.log:  
product:        Fedora
reason:         UnicodeDecodeError: 'ascii' codec can't decode byte 0xe0 in position 3: ordinal not in range(128)
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19

Comment 16 Kamil Páral 2013-06-18 11:04:20 UTC
I can confirm the problem for Marathi using F19 TC5 Live. However, again it seems to act weirdly:

Czech autoselected -> change to Marathi -> CRASH
English autoselected (without network) -> change to Marathi -> OK
English autoselected (with network) -> change to Marathi -> CRASH

Is the geolocation library messing up with app locale?

Comment 17 Martin Kolman 2013-06-18 14:31:54 UTC
Fix has been pushed to master & f19-branch.

(In reply to Kamil Páral from comment #16)
> I can confirm the problem for Marathi using F19 TC5 Live. However, again it
> seems to act weirdly:
> 
> Czech autoselected -> change to Marathi -> CRASH
> English autoselected (without network) -> change to Marathi -> OK
> English autoselected (with network) -> change to Marathi -> CRASH
> 
> Is the geolocation library messing up with app locale?
The issue was actually caused by pre-setting the timezone (which clashed with a translated string). So if it pre-set a language, it means it also preset a timezone with a wrongly encoded string.

Even if English was preset, the timezone could still be also pre-set from GeoIP if:
* the given territory has more than one language specified (English is used)
* a territory that uses English was detected

Anyway, it should be fixed by correctly encoding the timezone string.

Comment 18 Parag Nemade 2013-06-18 14:52:29 UTC
I can't find this build on koji nor even your commit to scm-commits list and also not at http://pkgs.fedoraproject.org/cgit/anaconda.git/?h=f19

Comment 19 Kamil Páral 2013-06-18 15:10:28 UTC
Parag, I believe this has been committed to anaconda git [1] and once an updated package is available, the bug will move to ON_QA status.

[1] https://git.fedorahosted.org/git/anaconda.git

Comment 20 Alexander Verbitsky 2013-06-19 15:39:11 UTC
Description of problem:
1. Run following commands:
su
./anaconda

2. Select language 'Russain'

Version-Release number of selected component:
anaconda-19.30.8-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /usr/sbin/anaconda
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=LIVE rootfstype=vfat ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
core_backtrace: 
executable:     /usr/sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 72, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 356, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 68, in _on_continue_clicked
    cb()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 479, in _on_continue_clicked
    nextAction.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 361, in refresh
    self._createBox()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 213, in _createBox
    self._updateCompleteness(spoke)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 259, in _updateCompleteness
    spoke.selector.set_property("status", spoke.status)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/datetime_spoke.py", line 396, in status
    return _("%s timezone") % self.data.timezone.timezone
UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in range(128)

Comment 21 Adam Williamson 2013-06-19 16:18:50 UTC
Discussed at 2013-06-19 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-19/f19final-blocker-review-7.2013-06-19-16.01.log.txt . Accepted as a blocker per criterion "The installer must run when launched normally from the release-blocking images."

Comment 22 Kamil Páral 2013-06-20 20:53:13 UTC
This is either not fixed completely in anaconda 19.30.9 or it caused further regressions. Please see bug 976576.

Comment 23 Fedora Update System 2013-06-20 23:37:22 UTC
anaconda-19.30.9-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-11350/anaconda-19.30.9-1.fc19

Comment 24 Adam Williamson 2013-06-21 00:11:21 UTC
Kamil: it looks to me rather like *this bug* is fixed, but there is a similar but separate bug in the partitioning code. I think you may have just hit https://bugzilla.redhat.com/show_bug.cgi?id=973019 .

Comment 25 Kamil Páral 2013-06-21 09:18:23 UTC
Ah, good catch, Adam. That's quite possible. In that case this would be VERIFIED.

Comment 26 Fedora Update System 2013-06-22 02:30:42 UTC
anaconda-19.30.9-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.