Bug 976576 - UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 4: ordinal not in range(128)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 4: ordin...
Status: CLOSED DUPLICATE of bug 973384
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:2b310f1b50361715e1954a1112e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 16:49 EDT by Kamil Páral
Modified: 2013-06-24 12:47 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 12:42:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (412.79 KB, text/plain)
2013-06-20 16:49 EDT, Kamil Páral
no flags Details
File: anaconda.log (10.77 KB, text/plain)
2013-06-20 16:49 EDT, Kamil Páral
no flags Details
File: environ (440 bytes, text/plain)
2013-06-20 16:49 EDT, Kamil Páral
no flags Details
File: lsblk_output (2.05 KB, text/plain)
2013-06-20 16:49 EDT, Kamil Páral
no flags Details
File: messages (148.05 KB, text/plain)
2013-06-20 16:49 EDT, Kamil Páral
no flags Details
File: nmcli_dev_list (3.36 KB, text/plain)
2013-06-20 16:49 EDT, Kamil Páral
no flags Details
File: os_info (179 bytes, text/plain)
2013-06-20 16:49 EDT, Kamil Páral
no flags Details
File: program.log (44.80 KB, text/plain)
2013-06-20 16:49 EDT, Kamil Páral
no flags Details
File: storage.log (189.39 KB, text/plain)
2013-06-20 16:49 EDT, Kamil Páral
no flags Details
File: ifcfg.log (567 bytes, text/plain)
2013-06-20 16:49 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-06-20 16:49:11 EDT
Description of problem:
I tried to reproduce bug 975159. With TC6, it doesn't crash on the initial screen, which is fine. But it crashes during creating disk partitions instead.

Version-Release number of selected component:
anaconda-19.30.9-1.fc19.x86_64

The following was filed automatically by anaconda:
anaconda 19.30.9-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 451, in execute
    msg = _("Creating %(type)s on %(device)s") % {"type": self.device.format.type, "device": self.device.path}
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 310, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 140, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 4: ordinal not in range(128)

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-TC rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64, python-blivet-0.16-1.fc19.noarch
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19
Comment 1 Kamil Páral 2013-06-20 16:49:18 EDT
Created attachment 763584 [details]
File: anaconda-tb
Comment 2 Kamil Páral 2013-06-20 16:49:22 EDT
Created attachment 763585 [details]
File: anaconda.log
Comment 3 Kamil Páral 2013-06-20 16:49:26 EDT
Created attachment 763586 [details]
File: environ
Comment 4 Kamil Páral 2013-06-20 16:49:30 EDT
Created attachment 763587 [details]
File: lsblk_output
Comment 5 Kamil Páral 2013-06-20 16:49:34 EDT
Created attachment 763588 [details]
File: messages
Comment 6 Kamil Páral 2013-06-20 16:49:38 EDT
Created attachment 763589 [details]
File: nmcli_dev_list
Comment 7 Kamil Páral 2013-06-20 16:49:42 EDT
Created attachment 763590 [details]
File: os_info
Comment 8 Kamil Páral 2013-06-20 16:49:46 EDT
Created attachment 763591 [details]
File: program.log
Comment 9 Kamil Páral 2013-06-20 16:49:50 EDT
Created attachment 763592 [details]
File: storage.log
Comment 10 Kamil Páral 2013-06-20 16:49:54 EDT
Created attachment 763593 [details]
File: ifcfg.log
Comment 11 Adam Williamson 2013-06-20 20:10:39 EDT
This may be the same as https://bugzilla.redhat.com/show_bug.cgi?id=973019 - that one's during partitioning too. The fix didn't quite make TC6.
Comment 12 Adam Williamson 2013-06-21 13:23:03 EDT
Vpodzime, can you check if this is the same as 973019 and dupe it off if so? Would help clean things up.
Comment 13 Adam Williamson 2013-06-24 12:42:53 EDT

*** This bug has been marked as a duplicate of bug 973384 ***

Note You need to log in before you can comment on or make changes to this bug.