Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 975209 - rhevm-iso-uploader fails with "error: no such option: --rhevm" error no matter what options are passed
Summary: rhevm-iso-uploader fails with "error: no such option: --rhevm" error no matte...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-iso-uploader
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.3.0
Assignee: Sandro Bonazzola
QA Contact: Ilanit Stein
URL:
Whiteboard: integration
Depends On:
Blocks: 975416
TreeView+ depends on / blocked
 
Reported: 2013-06-17 20:07 UTC by Joe Mann
Modified: 2018-12-01 14:23 UTC (History)
10 users (show)

Fixed In Version: rhevm-iso-uploader-3.3.0-0.0.master.el6ev
Doc Type: Bug Fix
Doc Text:
After an upgrade from version 3.1, the rhevm-iso-uploader could not upload images to the ISO storage domain because it used the deprecated configuration key 'rhevm' instead of 'engine'. This update adds a warning that the user needs to update the 'rhevm' key in the /etc/ovirt-engine/isouploader.conf file in order to use the rhevm-iso-uploader tool.
Clone Of:
: 975347 975416 (view as bug list)
Environment:
Last Closed: 2014-01-21 16:31:04 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 401543 0 None None None Never
Red Hat Product Errata RHBA-2014:0077 0 normal SHIPPED_LIVE rhevm-iso-uploader bug fix and enhancement update 2014-01-21 20:36:29 UTC
oVirt gerrit 15815 0 None None None Never

Description Joe Mann 2013-06-17 20:07:41 UTC
Description of problem:

When attempting to use the rhevm-iso-uploader to upload an ISO image to an ISO storage domain, the action fails with the following errors:

rhevm-iso-uploader: error: no such option: --rhevm

Command fails with the same error no matter the options used:

[root@rhev3-m ~]# rhevm-iso-uploader
Usage: rhevm-iso-uploader [options] list 
       rhevm-iso-uploader [options] upload FILE [FILE]...[FILE]

rhevm-iso-uploader: error: no such option: --rhevm


[root@rhev3-m ~]# rhevm-iso-uploader list --iso-domain=mku-iso
Usage: rhevm-iso-uploader [options] list 
       rhevm-iso-uploader [options] upload FILE [FILE]...[FILE]

rhevm-iso-uploader: error: no such option: --rhevm


Version-Release number of selected component (if applicable):
rhevm-iso-uploader-3.2.2-1.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Use the rhevm-iso-uploader in any manner


Actual results:
Fails with error

Expected results:
rhevm-iso-uploader should perform as expected

Additional info:
Both the customer's environment as well as my internal test evnrionment were upgraded from RHEV 3.1, not a fresh install of 3.2

Comment 1 Sandro Bonazzola 2013-06-18 07:26:54 UTC
Patch pushed upstream master

Comment 3 Sandro Bonazzola 2013-06-18 10:48:06 UTC
patch merged upstream master for 3.3.0:
http://gerrit.ovirt.org/gitweb?p=ovirt-iso-uploader.git;a=commit;h=c1a21cab52fc3e35d474b50f70d3555cd4ff51c0

Comment 6 Ilanit Stein 2013-09-08 13:04:15 UTC
Verified on is12 (rhevm-iso-uploader-3.3.0-0.3.rc.el6ev.noarch).

Comment 7 errata-xmlrpc 2014-01-21 16:31:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0077.html


Note You need to log in before you can comment on or make changes to this bug.