Bug 975291 - The boot option "Boot(Basic Video)" should not appear in Boot Menu
The boot option "Boot(Basic Video)" should not appear in Boot Menu
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: Regression
Depends On: 868762 1167768
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 23:21 EDT by haiyang,dong
Modified: 2014-11-25 06:36 EST (History)
16 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-3.el6
Doc Type: Bug Fix
Doc Text:
Incorrect boot entries were being displayed to the user. This was because incorrect boot entries remained in the grub configuration.This was fixed by removing the incorrect boot entries, so only valid boot entries are shown to the user.
Story Points: ---
Clone Of: 868762
Environment:
Last Closed: 2014-01-21 14:41:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached Screenshot for boot menu (168.08 KB, image/png)
2013-06-17 23:21 EDT, haiyang,dong
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 30422 master MERGED RHEV-H ONLY: correct boot menu options due to livecd-tools update Never

  None (edit)
Description haiyang,dong 2013-06-17 23:21:03 EDT
Created attachment 762275 [details]
attached Screenshot for boot menu

+++ This bug was initially created as a clone of Bug #868762 +++

Description of problem:
Insert the installation media(CD-ROM/USB), and start the system, When the automatic boot prompt appears, press Enter.
        Automatic boot in 30 seconds...
Select the "Boot(Basic Video)" option, and press Enter.
Actually it boot the the Hypervisor installer process, not the Hypervisor

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20121015.1.el6

How reproducible:
100%
 
Steps to Reproduce:
1.Insert the installation media(CD-ROM/USB), and start the system.
2.Start the system. When the automatic boot prompt appears, press Enter.
        Automatic boot in 30 seconds...
3.Select the "Boot(Basic Video)" option, and press Enter.


Actual result:
After step 3,Boot the Hypervisor installer process, not the the Hypervisor

Expect result:
After step 3,Boot the Hypervisor from CD media in Basic Video mode should be successful.

Additional info:
the difference of "Boot(Basic Video)" and "install(Basic video)":
Boot (Basic Video)
Boot the Hypervisor in Basic Video mode.
Install (Basic Video)
Install the Hypervisor in Basic Video mode.
Comment 1 haiyang,dong 2013-06-17 23:22:01 EDT
Can reproduce this issue in jenkins build:
http://jenkins.virt.bos.redhat.com/jenkins/view/RHEL%206/job/rhev-hypervisor-6/lastSuccessfulBuild/artifact/rhev-hypervisor6-6.5-20130222.0.auto1681.el6.iso

so it's a regression bug from rhev-h 6.4.z to rhev-h 6.5
Comment 5 haiyang,dong 2013-10-20 02:31:27 EDT
Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6

Tested as follows:
1.Insert the installation media(CD-ROM/USB), and start the system.
2.Start the system. When the automatic boot prompt appears, press Enter.
        Automatic boot in 30 seconds...

Notice that "Boot(Basic Video)" has been remove from boot option list
so this bug has been fixed, change the status into "VERIFIED"
Comment 7 Cheryn Tan 2013-11-07 19:28:09 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 errata-xmlrpc 2014-01-21 14:41:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.