Bug 976473 - Unable to export BPMN2 process to PDF file
Unable to export BPMN2 process to PDF file
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity medium
: ER5
: 6.0.0
Assigned To: Tihomir Surdilovic
Marek Baluch
:
: 998632 (view as bug list)
Depends On: 1031155
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 11:59 EDT by Sona Mala
Modified: 2014-08-26 10:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Unable to export BPMN2 process to PDF file. Consequence: The browser which populates after clicking on the "Export to pdf" feature cannot find the file which needs to be created in pdf format. Fix: Both share and download are now functional for png and pdf. Fix was implemented in designer master and 6.0.x branches. Result: The required BPMN2 process can now be exported to pdf.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:09:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sona Mala 2013-06-20 11:59:08 EDT
Description of problem:
If you click on icon "PDF" in the south toolbar, then browser cannot find file http://localhost:8080/business-central/transformer?uuid=default://master@jbpm-playground/HR/src/main/resources/myProc.bpmn2&profile=jbpm.

Version-Release number of selected component (if applicable):
6.0.0 DR5 (Beta3)


Steps to Reproduce:
1. create new process
2. export to PDF

Actual results:
File http://localhost:8080/business-central/transformer?uuid=default://master@jbpm-playground/HR/src/main/resources/myProc.bpmn2&profile=jbpm is not found by browser.

Expected results:
Download dialog for PDF file, which contains process diagram

Additional info:
Comment 1 Kris Verlaenen 2013-09-03 10:32:35 EDT
*** Bug 998632 has been marked as a duplicate of this bug. ***
Comment 2 Tihomir Surdilovic 2013-10-04 10:56:13 EDT
Both share and download should be functional now for both png and pdf. Fix in designer master and 6.0.x branches.
Comment 5 Ryan Zhang 2013-10-08 03:34:44 EDT
This is not picked in sync.2013.10.02. Remove ER4 as Target milestone.
Comment 7 Kanchan Desai 2013-10-28 13:44:14 EDT
Hi Sona,

Doc Text has been added. Can you please review the CCFR.
Comment 8 Marek Baluch 2013-11-27 05:20:29 EST
Verification blocked on https://bugzilla.redhat.com/show_bug.cgi?id=1031155.
Comment 9 Marek Baluch 2013-12-21 04:45:52 EST
Verified on ER6.

Note You need to log in before you can comment on or make changes to this bug.