Bug 976630 - UnicodeDecodeError: 'ascii' codec can't decode byte 0xe0 in position 11: ordinal not in range(128)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe0 in position 11: ordi...
Status: CLOSED DUPLICATE of bug 973384
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:2b310f1b50361715e1954a1112e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-21 00:32 EDT by Parag Nemade
Modified: 2013-06-24 12:47 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 12:43:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (280.61 KB, text/plain)
2013-06-21 00:32 EDT, Parag Nemade
no flags Details
File: anaconda.log (10.44 KB, text/plain)
2013-06-21 00:32 EDT, Parag Nemade
no flags Details
File: environ (440 bytes, text/plain)
2013-06-21 00:32 EDT, Parag Nemade
no flags Details
File: lsblk_output (2.04 KB, text/plain)
2013-06-21 00:32 EDT, Parag Nemade
no flags Details
File: messages (128.14 KB, text/plain)
2013-06-21 00:32 EDT, Parag Nemade
no flags Details
File: nmcli_dev_list (3.38 KB, text/plain)
2013-06-21 00:33 EDT, Parag Nemade
no flags Details
File: os_info (179 bytes, text/plain)
2013-06-21 00:33 EDT, Parag Nemade
no flags Details
File: program.log (22.97 KB, text/plain)
2013-06-21 00:33 EDT, Parag Nemade
no flags Details
File: storage.log (102.01 KB, text/plain)
2013-06-21 00:33 EDT, Parag Nemade
no flags Details
File: ifcfg.log (567 bytes, text/plain)
2013-06-21 00:33 EDT, Parag Nemade
no flags Details

  None (edit)
Description Parag Nemade 2013-06-21 00:32:31 EDT
Description of problem:
Fedora 19 Final TC6 iso installation gives this error. I completed storage with automatic settings and clicked on Forward and got this error

Version-Release number of selected component:
anaconda-19.30.9-1.fc19.x86_64

The following was filed automatically by anaconda:
anaconda 19.30.9-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 451, in execute
    msg = _("Creating %(type)s on %(device)s") % {"type": self.device.format.type, "device": self.device.path}
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 310, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 140, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe0 in position 11: ordinal not in range(128)

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-TC rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64, python-blivet-0.16-1.fc19.noarch
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19
Comment 1 Parag Nemade 2013-06-21 00:32:38 EDT
Created attachment 763636 [details]
File: anaconda-tb
Comment 2 Parag Nemade 2013-06-21 00:32:42 EDT
Created attachment 763637 [details]
File: anaconda.log
Comment 3 Parag Nemade 2013-06-21 00:32:46 EDT
Created attachment 763638 [details]
File: environ
Comment 4 Parag Nemade 2013-06-21 00:32:50 EDT
Created attachment 763639 [details]
File: lsblk_output
Comment 5 Parag Nemade 2013-06-21 00:32:55 EDT
Created attachment 763640 [details]
File: messages
Comment 6 Parag Nemade 2013-06-21 00:33:00 EDT
Created attachment 763641 [details]
File: nmcli_dev_list
Comment 7 Parag Nemade 2013-06-21 00:33:04 EDT
Created attachment 763642 [details]
File: os_info
Comment 8 Parag Nemade 2013-06-21 00:33:09 EDT
Created attachment 763643 [details]
File: program.log
Comment 9 Parag Nemade 2013-06-21 00:33:14 EDT
Created attachment 763644 [details]
File: storage.log
Comment 10 Parag Nemade 2013-06-21 00:33:18 EDT
Created attachment 763645 [details]
File: ifcfg.log
Comment 11 Lukas Brabec 2013-06-21 06:14:55 EDT
I just tried to install Fedora 19 TC6 Live x86_64 with autoselected czech, all default (reclaim space), when I hit begin button I got traceback. It seems to be similar to bugs 975159 and 973019.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-TC rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64, python-blivet-0.16-1.fc19.noarch
package:        anaconda-19.30.9-1.fc19.x86_64
packaging.log:  
product:        Fedora
reason:         UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 4: ordinal not in range(128)
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 12 Kamil Páral 2013-06-21 06:22:29 EDT
This is probably a duplicate of bug 973019.
Comment 13 Stéphane Raimbault 2013-06-23 17:06:51 EDT
The installer has crashed after entering my password

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang fr_FR.utf8
cmdline_file:   initrd=initrd0.img root=live:UUID=404D-864C rootfstype=vfat ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64, python-blivet-0.16-1.fc19.noarch
package:        anaconda-19.30.9-1.fc19.x86_64
packaging.log:  
product:        Fedora
reason:         UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 2: ordinal not in range(128)
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 14 Stéphane Raimbault 2013-06-23 17:22:00 EDT
I need to install in English to workaround this bug.
Comment 15 Adam Williamson 2013-06-24 12:43:29 EDT

*** This bug has been marked as a duplicate of bug 973384 ***

Note You need to log in before you can comment on or make changes to this bug.