Bug 976760 - [RHS-C] ovirt-engine-notifier[10280] ERROR run:593 Error: Directory '/usr/share/jboss-as' is required but missing
[RHS-C] ovirt-engine-notifier[10280] ERROR run:593 Error: Directory '/usr/sha...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: Sahina Bose
Prasanth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-21 07:44 EDT by Prasanth
Modified: 2013-09-23 18:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: bb6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16762 None None None Never

  None (edit)
Description Prasanth 2013-06-21 07:44:36 EDT
Description of problem:

ovirt-engine-notifier[10280] ERROR run:593 Error: Directory '/usr/share/jboss-as' is required but missing

Version-Release number of selected component (if applicable):  Red Hat Storage Console Version: 2.1.0-0.bb4.el6rhs 


How reproducible: Always


Steps to Reproduce:
1. Try to start ovirt-engine-notifier using # /etc/init.d/ovirt-engine-notifier start


Actual results:

----------------------------
# /etc/init.d/ovirt-engine-notifier start
Starting oVirt Engine Notifier:                            [FAILED]

# tailf /var/log/messages
Jun 21 17:06:34 rhs-client3 ovirt-engine-notifier[10260] ERROR run:593 Error: Directory '/usr/share/jboss-as' is required but missing
Jun 21 17:06:35 rhs-client3 ovirt-engine-notifier[10280] ERROR run:593 Error: Directory '/usr/share/jboss-as' is required but missing
Jun 21 17:08:52 rhs-client3 ovirt-engine-notifier[10336] ERROR run:593 Error: Directory '/usr/share/jboss-as' is required but missing
Jun 21 17:11:37 rhs-client3 ovirt-engine-notifier[10378] ERROR run:593 Error: Directory '/usr/share/jboss-as' is required but missing
Jun 21 17:11:38 rhs-client3 ovirt-engine-notifier[10397] ERROR run:593 Error: Directory '/usr/share/jboss-as' is required but missing
Jun 21 17:14:23 rhs-client3 ovirt-engine-notifier[10421] ERROR run:593 Error: Directory '/usr/share/jboss-as' is required but missing
----------------------------


Expected results: The service should start successfully


Additional info:
Comment 2 Prasanth 2013-07-08 07:21:14 EDT
The service now appears to be starting but the status and log says the following:

---------------
[root@rhs-client3 notifier]# /etc/init.d/ovirt-engine-notifier start
Starting oVirt Engine Notifier:                            [  OK  ]

[root@rhs-client3 notifier]# /etc/init.d/ovirt-engine-notifier status
 dead but pid file exists

[root@rhs-client3 notifier]# cat console.log 
Traceback (most recent call last):
  File "/usr/lib64/python2.6/logging/handlers.py", line 799, in emit
    self._connect_unixsocket(self.address)
  File "/usr/lib64/python2.6/logging/handlers.py", line 731, in _connect_unixsocket
    self.socket.connect(address)
  File "<string>", line 1, in connect
error: [Errno 91] Protocol wrong type for socket

[root@rhs-client3 notifier]# service ovirt-engine-notifier stop
Stopping oVirt Engine Notifier:                            [FAILED]
---------------

Hence, moving back to Assigned
Comment 3 Sahina Bose 2013-07-15 04:40:54 EDT
Set all MAIL related configurations in /usr/share/ovirt-engine/conf/notifier.conf.defaults and then start the ovirt-engine-notifier service.
Comment 4 Sahina Bose 2013-07-17 05:45:51 EDT
Fixed in bb6
Comment 6 Sahina Bose 2013-07-18 10:59:24 EDT
Have you set the configuration as per comment #3?
Comment 7 Prasanth 2013-07-21 01:16:31 EDT
(In reply to Sahina Bose from comment #6)
> Have you set the configuration as per comment #3?

Yes!

[root@rhs-client3 ~]# grep "MAIL_SERVER" /usr/share/ovirt-engine/conf/notifier.conf.defaults
MAIL_SERVER=rhs-client3.lab.eng.blr.redhat.com
[root@rhs-client3 ~]# /etc/init.d/ovirt-engine-notifier start
Starting oVirt Engine Notifier:                            [  OK  ]
[root@rhs-client3 ~]# /etc/init.d/ovirt-engine-notifier status
 dead but pid file exists

Can you confirm the exact configuration file to be modified and all the mandatory fields to be filled for successfully starting the service?

Also, if the MAIL_SERVER is not defined, we should be getting a meaningful error message something like: "Error: $MAIL_SERVER is not defined, please check for this in configuration file" instead of simply starting the service and showing the status as "dead but pid file exists"
Comment 8 Sahina Bose 2013-07-24 09:07:05 EDT
Please set all the configuration values in /usr/share/ovirt-engine/conf/notifier.conf.defaults and start the service
MAIL_SERVER=

MAIL_USER=


MAIL_PASSWORD=


MAIL_FROM=


MAIL_REPLY_TO=

There's an issue with logging where proper message is not logged if values are not set.
Comment 9 Prasanth 2013-07-29 05:17:02 EDT
Verified as fixed in bb6. 

ovirt-engine-notifier now seems to start fine once the required configuration values are set in /usr/share/ovirt-engine/conf/notifier.conf.defaults file. 

I've logged separate bugs for the problems with the error message and log file. Bug 989382 & Bug 989422
Comment 10 Scott Haines 2013-09-23 18:25:49 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.