Bug 989382
| Summary: | No error message seen while starting "ovirt-engine-notifier" when "MAIL_SERVER" is NOT defined | ||||||
|---|---|---|---|---|---|---|---|
| Product: | Red Hat Enterprise Virtualization Manager | Reporter: | Prasanth <pprakash> | ||||
| Component: | ovirt-engine-notification-service | Assignee: | Martin Perina <mperina> | ||||
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Petr Beňas <pbenas> | ||||
| Severity: | medium | Docs Contact: | |||||
| Priority: | medium | ||||||
| Version: | 3.3.0 | CC: | aberezin, acathrow, alonbl, chetan, dpati, dtsang, iheim, knarra, mmahoney, pbenas, pprakash, psriniva, pstehlik, Rhev-m-bugs, rhs-bugs, sabose, sasundar, shtripat, ssampat, yeylon, yzaslavs | ||||
| Target Milestone: | --- | ||||||
| Target Release: | 3.4.0 | ||||||
| Hardware: | Unspecified | ||||||
| OS: | Unspecified | ||||||
| Whiteboard: | infra | ||||||
| Fixed In Version: | ovirt-3.4.0-alpha1 | Doc Type: | Known Issue | ||||
| Doc Text: |
If the MAIL_SERVER parameter is not defined, any errors with starting the ovirt-engine-notifier are not reported, hence it is difficult to determine if the service has started successfully. To work around this issue, check the status of the service by using this command:
# service ovirt-engine-notifier status
|
Story Points: | --- | ||||
| Clone Of: | |||||||
| : | 998928 1058635 (view as bug list) | Environment: | |||||
| Last Closed: | Type: | Bug | |||||
| Regression: | --- | Mount Type: | --- | ||||
| Documentation: | --- | CRM: | |||||
| Verified Versions: | Category: | --- | |||||
| oVirt Team: | Infra | RHEL 7.3 requirements from Atomic Host: | |||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||
| Embargoed: | |||||||
| Bug Depends On: | 989422 | ||||||
| Bug Blocks: | 957769, 1058635 | ||||||
| Attachments: |
|
||||||
|
Description
Prasanth
2013-07-29 07:49:49 UTC
The issue still exists so moving back to Assigned Yair, What about this one? Alon infra will take ownership of tihs one. To summarize: Any error of service startup should be written to the service log file: /var/log/ovirt-engine/notifier/notifier.log The problem in rhel is that for some reason the log file is created but no messages are written into. This works OK on fedora with the same configuration. Can you see an error in /var/log/ovirt-engine/notifier/notifier.log? In particular there should be something like: Check configuration file, 'MAIL_SERVER' is missing If your notifier.log is empty, then it's a problem described in http://bugzilla.redhat.com/989422 (In reply to Martin Perina from comment #6) > Can you see an error in /var/log/ovirt-engine/notifier/notifier.log? In > particular there should be something like: > > Check configuration file, 'MAIL_SERVER' is missing > > If your notifier.log is empty, then it's a problem described in > http://bugzilla.redhat.com/989422 Yes, I can see the following in the logs: ------------- 2013-08-19 15:57:19,584 ERROR [org.ovirt.engine.core.notifier.Notifier] Failed to run the event notification service. java.lang.IllegalArgumentException: Check configuration file, 'MAIL_SERVER' is missing at org.ovirt.engine.core.notifier.Notifier.main(Notifier.java:82) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:606) at org.jboss.modules.Module.run(Module.java:270) at org.jboss.modules.Main.main(Main.java:411) ------------- (In reply to Prasanth from comment #7) > (In reply to Martin Perina from comment #6) > > Can you see an error in /var/log/ovirt-engine/notifier/notifier.log? In > > particular there should be something like: > > > > Check configuration file, 'MAIL_SERVER' is missing > > > > If your notifier.log is empty, then it's a problem described in > > http://bugzilla.redhat.com/989422 > > Yes, I can see the following in the logs: > > ------------- > 2013-08-19 15:57:19,584 ERROR [org.ovirt.engine.core.notifier.Notifier] > Failed to run the event notification service. > java.lang.IllegalArgumentException: Check configuration file, 'MAIL_SERVER' > is missing So we are ok. Strange how the jboss change does not effect your environment. So, your complain is that this error message is not displayed during execution of "/etc/init.d/ovirt-engine-notifier start"? Yes, the complaint is that, if MAIL_SERVER is not configured, service ovirt-engine-notifier start -> reports ok service ovirt-engine-notifier status -> says "dead but pif file exists" I have updated the doc text and attached the 2.1 RN as well. Please review the text and sign off. Created attachment 794664 [details]
This bug is documented as a known issue
Not exception material. Let's see if we can improve the text to tell a user that the service is starting rather than giving a successful return code. Moving to 3.4 Let's see if we get cycles to improve this in 3.3.z For systemd error is returned during start command, status command shows details. For initscripts error message is displayed during start command. ovirt 3.4.0 alpha has been released Verified in 3.4.0-0.7.beta2.el6.
[root@pb-rh34 ~]# /etc/init.d/ovirt-engine-notifier start
Starting oVirt Engine Notifier:
Validation result:
stderr: Check configuration file, 'MAIL_SERVER' is missing
Validation failed returncode is 1:
[FAILED]
[root@pb-rh34 ~]# /etc/init.d/ovirt-engine-notifier status
ovirt-engine-notifier is stopped
Closing as part of 3.4.0 |