Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 989382

Summary: No error message seen while starting "ovirt-engine-notifier" when "MAIL_SERVER" is NOT defined
Product: Red Hat Enterprise Virtualization Manager Reporter: Prasanth <pprakash>
Component: ovirt-engine-notification-serviceAssignee: Martin Perina <mperina>
Status: CLOSED CURRENTRELEASE QA Contact: Petr Beňas <pbenas>
Severity: medium Docs Contact:
Priority: medium    
Version: 3.3.0CC: aberezin, acathrow, alonbl, chetan, dpati, dtsang, iheim, knarra, mmahoney, pbenas, pprakash, psriniva, pstehlik, Rhev-m-bugs, rhs-bugs, sabose, sasundar, shtripat, ssampat, yeylon, yzaslavs
Target Milestone: ---   
Target Release: 3.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: infra
Fixed In Version: ovirt-3.4.0-alpha1 Doc Type: Known Issue
Doc Text:
If the MAIL_SERVER parameter is not defined, any errors with starting the ovirt-engine-notifier are not reported, hence it is difficult to determine if the service has started successfully. To work around this issue, check the status of the service by using this command: # service ovirt-engine-notifier status
Story Points: ---
Clone Of:
: 998928 1058635 (view as bug list) Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Infra RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 989422    
Bug Blocks: 957769, 1058635    
Attachments:
Description Flags
This bug is documented as a known issue none

Description Prasanth 2013-07-29 07:49:49 UTC
Description of problem:

No error message seen while starting "ovirt-engine-notifier" when "MAIL_SERVER" is NOT defined

Version-Release number of selected component (if applicable):  Red Hat Storage Console Version: 2.1.0-0.bb6.el6rhs 


How reproducible: Always


Steps to Reproduce:
1. # /etc/init.d/ovirt-engine-notifier start
2 .# /etc/init.d/ovirt-engine-notifier status


Actual results:

[root@rhs-client3 conf]# /etc/init.d/ovirt-engine-notifier start
Starting oVirt Engine Notifier:                            [  OK  ]                                                                                                                           
[root@rhs-client3 conf]# /etc/init.d/ovirt-engine-notifier status
 dead but pid file exists


Expected results:

If the MAIL_SERVER is not defined, we should be getting a meaningful error message something like: "Error: $MAIL_SERVER is not defined, please check for this in configuration file" instead of simply starting the service and showing the status as "dead but pid file exists". In short, the error message should be proper and provide a useful message to the user.

Comment 2 Sahina Bose 2013-07-31 14:12:58 UTC
The issue still exists so moving back to Assigned

Comment 3 Alon Bar-Lev 2013-08-07 06:28:01 UTC
Yair,
What about this one?
Alon

Comment 4 Yair Zaslavsky 2013-08-12 12:45:12 UTC
infra will take ownership of tihs one.

Comment 5 Alon Bar-Lev 2013-08-13 10:12:18 UTC
To summarize:

Any error of service startup should be written to the service log file:

/var/log/ovirt-engine/notifier/notifier.log

The problem in rhel is that for some reason the log file is created but no messages are written into. This works OK on fedora with the same configuration.

Comment 6 Martin Perina 2013-08-13 10:43:41 UTC
Can you see an error in /var/log/ovirt-engine/notifier/notifier.log? In particular there should be something like:

Check configuration file, 'MAIL_SERVER' is missing

If your notifier.log is empty, then it's a problem described in http://bugzilla.redhat.com/989422

Comment 7 Prasanth 2013-08-19 10:29:14 UTC
(In reply to Martin Perina from comment #6)
> Can you see an error in /var/log/ovirt-engine/notifier/notifier.log? In
> particular there should be something like:
> 
> Check configuration file, 'MAIL_SERVER' is missing
> 
> If your notifier.log is empty, then it's a problem described in
> http://bugzilla.redhat.com/989422

Yes, I can see the following in the logs:

-------------
2013-08-19 15:57:19,584 ERROR [org.ovirt.engine.core.notifier.Notifier] Failed to run the event notification service. 
java.lang.IllegalArgumentException: Check configuration file, 'MAIL_SERVER' is missing
        at org.ovirt.engine.core.notifier.Notifier.main(Notifier.java:82)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:606)
        at org.jboss.modules.Module.run(Module.java:270)
        at org.jboss.modules.Main.main(Main.java:411)
-------------

Comment 8 Alon Bar-Lev 2013-08-19 10:53:56 UTC
(In reply to Prasanth from comment #7)
> (In reply to Martin Perina from comment #6)
> > Can you see an error in /var/log/ovirt-engine/notifier/notifier.log? In
> > particular there should be something like:
> > 
> > Check configuration file, 'MAIL_SERVER' is missing
> > 
> > If your notifier.log is empty, then it's a problem described in
> > http://bugzilla.redhat.com/989422
> 
> Yes, I can see the following in the logs:
> 
> -------------
> 2013-08-19 15:57:19,584 ERROR [org.ovirt.engine.core.notifier.Notifier]
> Failed to run the event notification service. 
> java.lang.IllegalArgumentException: Check configuration file, 'MAIL_SERVER'
> is missing

So we are ok. Strange how the jboss change does not effect your environment.

Comment 9 Martin Perina 2013-08-27 12:07:56 UTC
So, your complain is that this error message is not displayed during execution of
"/etc/init.d/ovirt-engine-notifier start"?

Comment 10 Sahina Bose 2013-09-06 10:23:41 UTC
Yes, the complaint is that, if MAIL_SERVER is not configured,
service ovirt-engine-notifier start -> reports ok
service ovirt-engine-notifier status -> says "dead but pif file exists"

Comment 11 Pavithra 2013-09-06 10:35:35 UTC
I have updated the doc text and attached the 2.1 RN as well. Please review the text and sign off.

Comment 12 Pavithra 2013-09-06 11:10:01 UTC
Created attachment 794664 [details]
This bug is documented as a known issue

Comment 13 Andrew Cathrow 2013-09-16 13:30:13 UTC
Not exception material.
Let's see if we can improve the text to tell a user that the service is starting rather than giving a successful return code.

Moving to 3.4
Let's see if we get cycles to improve this in 3.3.z

Comment 14 Martin Perina 2014-01-09 13:35:02 UTC
For systemd error is returned during start command, status command shows details.
For initscripts error message is displayed during start command.

Comment 15 Sandro Bonazzola 2014-01-14 08:43:33 UTC
ovirt 3.4.0 alpha has been released

Comment 16 Petr Beňas 2014-02-17 16:20:49 UTC
Verified in  3.4.0-0.7.beta2.el6.

[root@pb-rh34 ~]# /etc/init.d/ovirt-engine-notifier start
Starting oVirt Engine Notifier: 
Validation result:
stderr: Check configuration file, 'MAIL_SERVER' is missing
Validation failed returncode is 1:
                                                           [FAILED]
[root@pb-rh34 ~]# /etc/init.d/ovirt-engine-notifier status
ovirt-engine-notifier is stopped

Comment 17 Itamar Heim 2014-06-12 14:09:31 UTC
Closing as part of 3.4.0