Bug 989422 - RHS-C: notifier.log is not available in /var/log/ovirt-engine/notifier/
RHS-C: notifier.log is not available in /var/log/ovirt-engine/notifier/
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Shubhendu Tripathi
Prasanth
:
Depends On: 984581 997426
Blocks: 989382 1058635
  Show dependency treegraph
 
Reported: 2013-07-29 05:06 EDT by Prasanth
Modified: 2014-01-28 03:44 EST (History)
11 users (show)

See Also:
Fixed In Version: bb8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17051 None None None Never

  None (edit)
Description Prasanth 2013-07-29 05:06:10 EDT
Description of problem:

notifier.log is not available in /var/log/ovirt-engine/notifier. Only "console.log" is present in it which is empty and doesn't seems to get updated. Is the location of the notifier log file something different?

Version-Release number of selected component (if applicable):  Red Hat Storage Console Version: 2.1.0-0.bb6.el6rhs 

# rpm -qa |grep rhsc
rhsc-backend-2.1.0-0.bb6.el6rhs.noarch
rhsc-restapi-2.1.0-0.bb6.el6rhs.noarch
rhsc-log-collector-2.1-0.1.el6rhs.noarch
rhsc-dbscripts-2.1.0-0.bb6.el6rhs.noarch
rhsc-sdk-2.1.0.0-0.bb3a.el6rhs.noarch
rhsc-tools-2.1.0-0.bb6.el6rhs.noarch
rhsc-2.1.0-0.bb6.el6rhs.noarch
rhsc-webadmin-portal-2.1.0-0.bb6.el6rhs.noarch
rhsc-cli-2.1.0.0-0.bb3a.el6rhs.noarch
rhsc-setup-2.1.0-0.bb6.el6rhs.noarch

How reproducible: Always


Steps to Reproduce:
1. Configure /usr/share/ovirt-engine/conf/notifier.conf.defaults with the required values
2. Start the service. #/etc/init.d/ovirt-engine-notifier start
3. Check for the corresponding logs in /var/log/ovirt-engine/notifier/

Actual results:

[root@rhs-client3 notifier]# pwd
/var/log/ovirt-engine/notifier
[root@rhs-client3 notifier]# ll
total 0
-rw-r--r--. 1 ovirt ovirt 0 Jul 29 14:07 console.log
[root@rhs-client3 notifier]# cat console.log 
[root@rhs-client3 notifier]#

Expected results: Logs related to ovirt-engine-notifier should be available in the respective log directory


Additional info:
Comment 2 Itamar Heim 2013-07-30 04:42:30 EDT
related to bug 984581?
Comment 3 Sahina Bose 2013-07-30 04:51:59 EDT
Itamar, thanks - yes, this is the same issue.
Comment 4 Prasanth 2013-08-07 02:35:45 EDT
Verified as fixed in bb8. 

notifier.log is now generated in /var/log/ovirt-engine/notifier once ovirt-engine-notifier service is started.

[root@rhs-client3 notifier]# pwd
/var/log/ovirt-engine/notifier
[root@rhs-client3 notifier]# ls -al notifier.log 
-rw-r--r--. 1 ovirt ovirt 31079 Aug  7 11:29 notifier.log
Comment 5 Scott Haines 2013-09-23 18:25:53 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.