Bug 976905 - Implement Volume Clone for GlusterFS Cinder Plugin
Implement Volume Clone for GlusterFS Cinder Plugin
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
4.0
Unspecified Unspecified
high Severity high
: Upstream M3
: 4.0
Assigned To: Eric Harney
Dafna Ron
https://blueprints.launchpad.net/cind...
: FutureFeature
Depends On: 1023065
Blocks: 961016 RHOS40RFE 1005887
  Show dependency treegraph
 
Reported: 2013-06-21 16:27 EDT by Tushar Katarki
Modified: 2016-04-26 14:44 EDT (History)
11 users (show)

See Also:
Fixed In Version: openstack-cinder-2013.2-0.9.b3.el6ost
Doc Type: Enhancement
Doc Text:
With this update, clones can now be created from GlusterFS Block Storage volumes and volume snapshots.
Story Points: ---
Clone Of:
: 1005887 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:08:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 38224 None None None Never

  None (edit)
Description Tushar Katarki 2013-06-21 16:27:51 EDT
Description of problem:

Cinder Volumes can be cloned in OpenStack Grizzly and are described below. 

https://blueprints.launchpad.net/cinder/+spec/add-cloning-support-to-cinder

This functionality should be implemented for GlusterFS Cinder plugin leveraging the work being done for Guest-Assisted Snaps (https://bugzilla.redhat.com/show_bug.cgi?id=975941). 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 14 Dafna Ron 2013-11-18 09:17:30 EST
bug https://bugzilla.redhat.com/show_bug.cgi?id=1023065 was fixed and move to verified. 
there are still some bugs that have not been fixed but we can assume that plan will go be at least 80% passed and so we move the RFE to verified.
Comment 17 errata-xmlrpc 2013-12-19 19:08:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.