Bug 977187 - sosreport should capture /etc/yaboot.conf as well as /boot/yaboot.conf
sosreport should capture /etc/yaboot.conf as well as /boot/yaboot.conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sos (Show other bugs)
5.8
powerpc Linux
unspecified Severity medium
: rc
: ---
Assigned To: Bryn M. Reeves
Filip Holec
: EasyFix
Depends On:
Blocks: 1001941 1001948 1001966
  Show dependency treegraph
 
Reported: 2013-06-23 23:29 EDT by David Gibson
Modified: 2016-04-18 06:25 EDT (History)
6 users (show)

See Also:
Fixed In Version: sos-1.7-9.65.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1001941 1001948 1001966 (view as bug list)
Environment:
Last Closed: 2013-09-30 20:37:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Gibson 2013-06-23 23:29:17 EDT
Description of problem:

sosreport on powerpc hardware takes a copy of /boot/yaboot.conf, but not /etc/yaboot.conf which is often more important.  It may depend on RHEL version, but I believe /boot/yaboot.conf is sometimes just a copy of the master /etc/yaboot.conf, necessary with some /boot configurations.  This information can be vital for debugging powerpc boot problems

Version-Release number of selected component (if applicable):

sos-1.7-9.62.el5.noarch

But same in current sources, afaict.

Steps to Reproduce:
1. Run sosreport on powerpc hardware

Actual results:

Generated report contains /boot/yaboot.conf (if present) but not /etc/yaboot.conf

Expected results:

Report contains both /etc/yaboot.conf and /boot/yaboot.conf (if present).
Comment 1 RHEL Product and Program Management 2013-06-23 23:57:20 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Bryn M. Reeves 2013-06-24 07:22:03 EDT
Wasn't this a symlink at some point (mirroring grub.conf)?

I'm happy to put this in 5.10 as long as we get the acks.
Comment 3 David Gibson 2013-06-24 19:54:28 EDT
It may have been, but I've hit at least one case where it's not.  So, it would be good to get both versions just in case.  If we grabbed a stat so the sosreport shows if it is a symlink or not would be even better, I guess.
Comment 5 Bryn M. Reeves 2013-07-24 09:24:49 EDT
$ cat sos-bz977187-add-etc-yaboot.patch
diff -up sos-1.7/lib/sos/plugins/bootloader.py.orig sos-1.7/lib/sos/plugins/bootloader.py
--- sos-1.7/lib/sos/plugins/bootloader.py.orig	2013-07-24 13:27:33.205291609 +0100
+++ sos-1.7/lib/sos/plugins/bootloader.py	2013-07-24 13:27:41.802324881 +0100
@@ -25,6 +25,7 @@ class bootloader(sos.plugintools.PluginB
         self.addCopySpec("/boot/grub/grub.conf")
         self.addCopySpec("/boot/grub/device.map")
         self.addCopySpec("/boot/yaboot.conf")
+        self.addCopySpec("/etc/yaboot.conf")
         
         self.collectExtOutput("/sbin/lilo -q")
         self.collectExtOutput("/bin/ls -laR /boot")
Comment 8 errata-xmlrpc 2013-09-30 20:37:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1356.html

Note You need to log in before you can comment on or make changes to this bug.