Bug 977525 - Step 3 uses the specific database name "network"
Step 3 uses the specific database name "network"
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Installation_and_Configuration_Guide (Show other bugs)
unspecified
x86_64 Linux
medium Severity medium
: ---
: 4.0
Assigned To: Summer Long
ecs-bugs
: Documentation
: 979111 (view as bug list)
Depends On:
Blocks: 1011085
  Show dependency treegraph
 
Reported: 2013-06-24 15:36 EDT by Robert Harker
Modified: 2013-09-24 13:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build: CSProcessor Builder Version 1.10 Build Name: 15807, Installation and Configuration Guide-3-1 Build Date: 12-06-2013 09:31:52 Topic ID: 15810-450294 [Latest]
Last Closed: 2013-07-24 15:14:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Chapter 9-Installing the OpenStack Networking Service (9.20 MB, application/pdf)
2013-06-27 22:09 EDT, Summer Long
no flags Details

  None (edit)
Description Robert Harker 2013-06-24 15:36:34 EDT
Title: Creating the OpenStack Networking Database

Describe the issue:
Section 9.2 Step 3 uses the specific database name "network" rather than the generic DBNAME used in step 2

Suggestions for improvement:
Update doc

Additional information:
Comment 2 Summer Long 2013-06-25 01:48:08 EDT
Reworded step 3, so that the 'network' name is used (used later this chapter, not just this procedure). However, kept note about recommended database names.
Ready for QA with next doc release.
Comment 4 Summer Long 2013-06-25 19:14:14 EDT
Sent in email as well. Have no idea whether Robert can access the file server...
Comment 5 Robert Harker 2013-06-25 19:37:43 EDT
I would suggest two solutions:
You could split the section into two tracks, Open vSwitch and Linux Bridge.
For packstack and Open vSwitch the database login name is quantum and the database is called ovs_quantum.  I am not sure what the database login name if for Linux Bridge.

A different solution would be to mostly drop Linux Bridge.  Use the quantum and ovs-quantum names and have a foot note explaining the different names for Linux Bridge.

I think the second solution is better since the direction OpenStack is taking is quantum.  Are there many people migrating from Nova Networking to Linux Bridge?  Is there a use case for existing Nova Network installations upgrading to Grizzly using Linux Bridge to preserve their Nova Networking configuration?

A third solution comes to mind.  Since the quantum name is on the way out because of trademark issues, maybe packstack should be changed to use the names network for database login name and database name.  I think this may be the best long term solution assuming that the name "network" is going to stick.

Also these changes will have to go into the next section at least, Configuring quantum.conf, if not others.  The bear of documentation, getting everything to agree.
Comment 6 Summer Long 2013-06-25 20:34:22 EDT
Thanks for that, Robert.

Yes, I thought about using either the open vswitch or linux bridge recommendations as the example, but because we are just days away from the release, have opted for the technically-accurate-that-won't break-anything-in-other-sections solution. So, if the 'network' name usage is at least now technically correct, am loathe to change it.

In version 4, anything to do with OS networking will be reworked and reworded to match the new neutron naming. I know that Packstack will be updated as well to match and anything 'quantum' will disappear.  Certainly ovs_quantum will go away.

Am wondering if I should just get rid of the recommendations for now? Then it's a clean install, having nothing to do with the packstack conventions.

thanks, Summer
Comment 8 Stephen Gordon 2013-06-27 12:13:47 EDT
(In reply to Robert Harker from comment #5)
> I would suggest two solutions:
> You could split the section into two tracks, Open vSwitch and Linux Bridge.
> For packstack and Open vSwitch the database login name is quantum and the
> database is called ovs_quantum.  I am not sure what the database login name
> if for Linux Bridge.
> 
> A different solution would be to mostly drop Linux Bridge.  Use the quantum
> and ovs-quantum names and have a foot note explaining the different names
> for Linux Bridge.
> 
> I think the second solution is better since the direction OpenStack is
> taking is quantum.  Are there many people migrating from Nova Networking to
> Linux Bridge?  Is there a use case for existing Nova Network installations
> upgrading to Grizzly using Linux Bridge to preserve their Nova Networking
> configuration?

Last information I received on this was that nova network -> linuxbridge is actually the easiest/most likely to work migration. When and how nova network is going to be obsoleted in the upstream project is still a hot topic though so there are still decisions to be made (and migration paths finalized) here.

Either way both linuxbridge and openvswitch are intended to be fully supported and on an equal footing here so I would ensure that the solution does not involve making one of them a footnote.
Comment 9 Stephen Gordon 2013-06-27 12:17:20 EDT
*** Bug 979111 has been marked as a duplicate of this bug. ***
Comment 11 Summer Long 2013-06-27 22:09:15 EDT
Created attachment 766384 [details]
Chapter 9-Installing the OpenStack Networking Service
Comment 12 Summer Long 2013-06-27 22:11:26 EDT
Previous comment w/o internal link:
Ok, if we're going to pick one, using the packstack default makes sense. Also makes sense to switch the service default to make it all consistent. Here are the changes:

9.2.1 Creating the OpenStack Networking Database - Switched 'network' to 'ovs_quantum', and 'network' user to 'quantum'.
9.2.2 Creating the OpenStack Networking Identity Records - Switched both user and service from 'network' to 'quantum'. Note: The whole tenant issue will be dealt with in 965943. (will be switching to using one tenant for all services)
9.4 Configuring the Networking Service - Switched user to 'quantum'. Updated with note about 'ovs_quantum' as the example database. 
9.5 Configuring the DHCP Agent - Switched user name to 'quantum'.

Robert, could you please do a review of this section please? I've attached a pdf of the chapter.
many thanks, Summer
Comment 13 Summer Long 2013-06-28 01:26:19 EDT
From Robert per email: "Looks good." Note: He found more issues with adjacent material, and will be raising another bug (or more).
Ready for QA with the next doc release.

Note You need to log in before you can comment on or make changes to this bug.