Bug 978376 - consumer/consumer group - how to update all pkgs on a consumer or group?
consumer/consumer group - how to update all pkgs on a consumer or group?
Status: CLOSED DUPLICATE of bug 979587
Product: Pulp
Classification: Community
Component: consumers (Show other bugs)
Unspecified Unspecified
unspecified Severity medium
: ---
: 2.3.0
Assigned To: Jeff Ortel
Preethi Thomas
: Triaged
Depends On:
Blocks: 950743
  Show dependency treegraph
Reported: 2013-06-26 09:31 EDT by Brad Buckingham
Modified: 2013-08-02 14:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-08-02 14:54:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brad Buckingham 2013-06-26 09:31:50 EDT
Description of problem:

From the pulp v2 documentation, it is unclear how to use the API to trigger an update of all packages on a consumer or consumer group.  The goal is to be able to perform the equivalent of a 'yum update' on a single consumer or on all consumers within a consumer group. 


  - http://pulp-dev-guide.readthedocs.org/en/pulp-2.1/integration/rest-api/consumer/content.html#update-content-on-a-consumer

  Note: There is an option for 'all'; however, based on discussion, it seems that the user must still pass in package names.

Consumer Group:

  Note: I don't see any content management docs for consumer groups.

Version-Release number of selected component (if applicable):
Comment 1 Michael Hrivnak 2013-08-02 14:54:27 EDT

*** This bug has been marked as a duplicate of bug 979587 ***

Note You need to log in before you can comment on or make changes to this bug.