Bug 97850 - ppp-watch usage output and manpage synopsis are inconsistent
ppp-watch usage output and manpage synopsis are inconsistent
Status: CLOSED DUPLICATE of bug 85447
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-06-23 04:14 EDT by Barry K. Nathan
Modified: 2014-03-16 22:37 EDT (History)
1 user (show)

See Also:
Fixed In Version: 7.31-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry K. Nathan 2003-06-23 04:14:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030619

Description of problem:
The command-line help for ppp-watch and the manpage for it have inconsistent
descriptions of ppp-watch's command line options.

Version-Release number of selected component (if applicable):
initscripts-7.24-2.92

How reproducible:
Always.

Steps to Reproduce:
1. Run "/sbin/ppp-watch" and read the usage output. (I know you're not supposed
to do this unless you're ifup-ppp, but just bear with me here.)
2. Run "man ppp-watch" and read the first few lines.

Actual Results:  
[root@i5000e root]# ppp-watch
usage: ppp-watch [ifcfg-]<logical-name> [boot]
[root@i5000e root]# man ppp-watch
PPP-WATCH(8)                                                      PPP-WATCH(8)
 
NAME
       ppp-watch  -  daemon  to make PPP interfaces act more like other inter-
       faces
 
SYNOPSIS
       ppp-watch interface-name [boot]
 
DESCRIPTION
[snip]

Expected Results:  
The "usage" and "SYNOPSIS" shouldn't be *this* different:

1. Is it an interface-name or a logical-name? (And what *is* a logical-name, for
that matter?)

2. Is the "ifcfg-" prefix permissible? (AFAICT it seems to be, so if that's the
case, then it's the manpage that needs to be updated.)

Additional info:

Consistent documentation for ppp-watch might help me figure out what's going on
with bug 97845 (and therefore might help me fix it).
Comment 1 Barry K. Nathan 2003-06-25 00:42:22 EDT
This is still the case in initscripts 7.25-1
Comment 2 Bill Nottingham 2003-09-03 23:49:25 EDT
Actually, I think the usage: is wrong. Fixed in 7.31-1.
Comment 3 Bill Nottingham 2003-09-03 23:59:46 EDT
Strike that, this is all sorts of wrong. Piggybacking this on another flame.

*** This bug has been marked as a duplicate of 85447 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:56:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.