Bug 979572 - vdsm-reg: rollback network configuration if addNetwork fails
vdsm-reg: rollback network configuration if addNetwork fails
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Alon Bar-Lev
network
: Triaged
: 979081 (view as bug list)
Depends On: 979081 979567 999123
Blocks: 979570
  Show dependency treegraph
 
Reported: 2013-06-28 16:17 EDT by Alon Bar-Lev
Modified: 2016-02-10 15:00 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-21 10:43:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alon Bar-Lev 2013-06-28 16:17:56 EDT
Continue discussion from bug#979081.

Currently vdsm-bootstrap, host-deploy, vdsm-reg do not rollback network configuration if addNetwork fails.

The sequence should be:
- addNetwork
- vdsm-restore-net-config -> rollback
- vdsm-store-net-config -> commit

vdsm-restore-net-config does not work on ovirt-node/rhev-h, waiting for bug#979567.

Best if we could avoid the bridge module anyway and perform all from engine, including the removal of brXXX bridges, so we do not need to maintain these deviations.
Comment 1 Dan Kenigsberg 2013-07-03 05:19:13 EDT
When is vdsm-reg's makeBridge code used these days? I thought it has been deprecated by ovirt-host-deploy.

If this corner case does not affect the master branch, and lacking customers complaining about this, I would rather not touch the vdsm-reg hornet nest.
Comment 2 Alon Bar-Lev 2013-07-19 20:31:39 EDT
(In reply to Dan Kenigsberg from comment #1)
> When is vdsm-reg's makeBridge code used these days? I thought it has been
> deprecated by ovirt-host-deploy.

vdsm-reg is not deprecated, it should have been replaced by bug#875088, so the logic is intact... as the unfortunate design creates the bridge before it tries to register.

> If this corner case does not affect the master branch, and lacking customers
> complaining about this, I would rather not touch the vdsm-reg hornet nest.

I agree, I opened this bug to get formal approval.
Comment 3 Dan Kenigsberg 2013-07-21 10:43:48 EDT
In this case, I suggest not to solve it. If this becomes urgently needed, and we end up touching vdsm-reg, I prefer to drop bridge creation from it, and let it be solved once in ovirt-host-deploy.
Comment 4 Dan Kenigsberg 2013-09-03 03:22:20 EDT
*** Bug 979081 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.