Bug 979765 - [rhevm-guest-agent_33] - RFE - Interface disabled within the VM OS should be reported in webadmin
[rhevm-guest-agent_33] - RFE - Interface disabled within the VM OS should be ...
Status: CLOSED DUPLICATE of bug 979771
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Barak
Pavel Stehlik
infra
:
Depends On: 770447
Blocks: 979771 979772
  Show dependency treegraph
 
Reported: 2013-06-30 07:28 EDT by David Botzer
Modified: 2016-02-10 14:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 979771 979772 (view as bug list)
Environment:
Last Closed: 2013-07-05 02:56:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs-DC33 (75.49 KB, application/x-gzip)
2013-06-30 07:28 EDT, David Botzer
no flags Details

  None (edit)
Description David Botzer 2013-06-30 07:28:45 EDT
Created attachment 767038 [details]
logs-DC33

Description of problem:
RFE - RHEV-Agent should report when Interface is disabled within the VM OS,  webadmin->VM Tab -> Network Interfaces subtub
for example, 'ifdown eth0' within the vm 

Version-Release number of selected component (if applicable):
3.3/is3
rhev-agent.x86_64 0:2.3.16-7.el6_2

How reproducible:
always

Steps to Reproduce:
1.install rhevm
2.create vm (rhel,Win)
3.open Spice console on VM
4.disable the Vnic within the console

Actual results:
VM's Vnic is displayed in webadmin as 'up' (link is up)

Expected results:
Should display VM's Vnic, in webadmin, as 'down' (link is down)

Additional info:
In addition, in Network Intercaes Subtub-> there is a guest agent data tab
Where its possible to display the reason - 
e.x user cmd initiated ifdown
e.x 
   Unplugged, no memory left, OS not responding / stuck
   Network loaded 99% traffic
Comment 1 David Botzer 2013-06-30 07:31:14 EDT
The dependencies should be: Engine depends on VDSM depends on Guest Agent.
Comment 2 Itamar Heim 2013-07-05 02:56:42 EDT

*** This bug has been marked as a duplicate of bug 979771 ***

Note You need to log in before you can comment on or make changes to this bug.