Bug 979771 - RFE - Interface state within the VM OS should be reported in webadmin
RFE - Interface state within the VM OS should be reported in webadmin
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.3.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Andrew Cathrow
yeylon@redhat.com
network
: FutureFeature
: 979765 979772 (view as bug list)
Depends On: 770447 979765 979772
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-30 08:16 EDT by David Botzer
Modified: 2016-04-18 02:59 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 979765
Environment:
Last Closed: 2013-08-04 06:17:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Botzer 2013-06-30 08:16:36 EDT
+++ This bug was initially created as a clone of Bug #979765 +++

Description of problem:
RFE - RHEV-Agent should report when Interface is disabled within the VM OS,  webadmin->VM Tab -> Network Interfaces subtub
for example, 'ifdown eth0' within the vm 

Version-Release number of selected component (if applicable):
3.3/is3
rhev-agent.x86_64 0:2.3.16-7.el6_2

How reproducible:
always

Steps to Reproduce:
1.install rhevm
2.create vm (rhel,Win)
3.open Spice console on VM
4.disable the Vnic within the console

Actual results:
VM's Vnic is displayed in webadmin as 'up' (link is up)

Expected results:
Should display VM's Vnic, in webadmin, as 'down' (link is down)

Additional info:
In addition, in Network Intercaes Subtub-> there is a guest agent data tab
Where its possible to display the reason - 
e.x user cmd initiated ifdown
e.x 
   Unplugged, no memory left, OS not responding / stuck
   Network loaded 99% traffic

--- Additional comment from David Botzer on 2013-06-30 07:31:14 EDT ---

The dependencies should be: Engine depends on VDSM depends on Guest Agent.
Comment 1 Itamar Heim 2013-07-05 02:56:24 EDT
*** Bug 979772 has been marked as a duplicate of this bug. ***
Comment 2 Itamar Heim 2013-07-05 02:56:42 EDT
*** Bug 979765 has been marked as a duplicate of this bug. ***
Comment 3 lpeer 2013-07-07 02:12:50 EDT
AFAIU this RFE is about changing the property we currently call link state to be an administrative link state and add a new property for link state that would reflect the real connectivity status (from within the guest all the way to the physical link on the host). 

I think there is a use to the administrative state as it indicates the configuration state from the admin POV (and if there is no guest agent it is the only state that has meaning).

Changing to RFE component as this change requires support in the guest agent, VDSM engine and UI.
Comment 4 Itamar Heim 2013-07-07 02:56:00 EDT
when i first read this, i thought this was about if the guest did ifdown on the interface from within the guest.
Comment 5 Dan Kenigsberg 2013-07-17 05:33:31 EDT
(In reply to Itamar Heim from comment #4)
> when i first read this, i thought this was about if the guest did ifdown on
> the interface from within the guest.

This was my understanding, too. Guest agent may report both IFF_LOWER_UP (carrier state, the thing controlled by libvirt's link state) and IFF_UP (the thing controlled by the guest OS). But I am not convinced that our customers are interested in this fine granularity; I do not expect any valid case where the link state is changed without the admin's direct intention.

Currently, the agent ignores non-IFF_UP interfaces. In my opinion, it would be enough for Engine to report the missing interfaces as "down", and show it greyed out with no IP address.
Comment 6 Andrew Cathrow 2013-07-18 07:51:29 EDT
(In reply to Dan Kenigsberg from comment #5)
> (In reply to Itamar Heim from comment #4)
> > when i first read this, i thought this was about if the guest did ifdown on
> > the interface from within the guest.
> 
> This was my understanding, too. Guest agent may report both IFF_LOWER_UP
> (carrier state, the thing controlled by libvirt's link state) and IFF_UP
> (the thing controlled by the guest OS). But I am not convinced that our
> customers are interested in this fine granularity; I do not expect any valid
> case where the link state is changed without the admin's direct intention.
> 
> Currently, the agent ignores non-IFF_UP interfaces. In my opinion, it would
> be enough for Engine to report the missing interfaces as "down", and show it
> greyed out with no IP address.

ACK

Note You need to log in before you can comment on or make changes to this bug.