Bug 980195 - unison227 incompatible with same version on other Distros: internal error: new archives are not identical
unison227 incompatible with same version on other Distros: internal error: ne...
Status: CLOSED DUPLICATE of bug 896649
Product: Fedora
Classification: Fedora
Component: unison227 (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 12:39 EDT by Daniel Riek
Modified: 2013-07-01 13:46 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 896649
Environment:
Last Closed: 2013-07-01 13:46:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Riek 2013-07-01 12:39:23 EDT
Smae problem on Fedora 19

+++ This bug was initially created as a clone of Bug #896649 +++

Description of problem:

Unison cannot synchronize with remote

Version-Release number of selected component (if applicable):

unison227-2.27.57-19.fc18.i686 (local)
unison227-2.27.57-17.fc17.i686 (remote)

How reproducible:

100%

Steps to Reproduce:
1. run unison, tell it OK when it prompts about unavailable archives/new roots
2.
3.
  
Actual results:

Popup:
"Fatal error

Internal error: New archives are not identical.
Retaining original archives.  Please run Unison again to bring them up to date."


Expected results:

prompt to make sync decisions, synchronize


Additional info:

Broke after upgrade from Fedora 17 to Fedora 18

See Bug 892830 for unison240. (same problem: CLOSED ERRATA)

--- Additional comment from Gregor Tätzner on 2013-01-17 12:17:17 EST ---

imho this is a good time to retire the old unison-227 package. that version is not maintained by upstream for...how many years?

Alternatively you would need to backport the fix from 2.40.102 that addresses the differences between ocaml 3 and 4.

--- Additional comment from Andrew McNabb on 2013-01-17 19:33:32 EST ---

This seems to be related to the following:

http://unix.stackexchange.com/q/52945/12336
https://trac.macports.org/ticket/35407

--- Additional comment from Daniel Riek on 2013-07-01 12:38:01 EDT ---

The same problem exists when trying to use a remote machine running RHEL and unison227-2.27.57-13.el6.x86_64 from EPEL.

Makes unison on Fedora useless.
Comment 1 Andrew McNabb 2013-07-01 13:46:24 EDT
There's really no need to clone the bug--it's better just to request the version number to be updated.

*** This bug has been marked as a duplicate of bug 896649 ***

Note You need to log in before you can comment on or make changes to this bug.