Bug 980534 - /usr/lib/debug CRC mismatch without build-id
/usr/lib/debug CRC mismatch without build-id
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpm (Show other bugs)
7.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Panu Matilainen
Aleš Mareček
:
Depends On: 971119
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 12:02 EDT by Jan Kratochvil
Modified: 2014-06-13 05:39 EDT (History)
15 users (show)

See Also:
Fixed In Version: rpm-4.11.1-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 971119
Environment:
Last Closed: 2014-06-13 05:39:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2013-07-02 12:02:47 EDT
Tracker for F-18-filed Bug with a patch:

+++ This bug was initially created as a clone of Bug #971119 +++

Description of problem:
rm -rf /usr/lib/debug/.build-id
GDB stops working.

Version-Release number of selected component (if applicable):
gdb-7.5.1-38.fc18.x86_64

How reproducible:
On one system.

Steps to Reproduce:
gdb cal

Actual results:
warning: the debug information found in "/usr/lib/debug//usr/bin/cal.debug" does not match "/usr/bin/cal" (CRC mismatch).

Expected results:
Reading symbols from /usr/bin/cal...Reading symbols from /usr/lib/debug/usr/bin/cal.debug...done.

Additional info:

--- Additional comment from Jan Kratochvil on 2013-06-13 15:38:07 CEST ---

The cal problem is due to dwz: Changing .debug file CRC not updating it in the main file referencing it.
Comment 1 Panu Matilainen 2013-07-05 05:50:22 EDT
Fixed in rpm >= 4.11.1-2.el7
Comment 3 Jan Kratochvil 2013-07-11 11:24:35 EDT
This bug is about /usr/lib/rpm/sepdebugcrcfix .

The missing top level symlinks is Bug 974130 which is also fixed now.

So it is best to test them now together and any /usr/lib/debug/**.debug file should load fine, even with deleted /usr/lib/debug/.build-id/ .

The correct loading is for example:
Reading symbols from /usr/bin/cal...Reading symbols from /usr/lib/debug/usr/bin/cal.debug...done.

I see I messed up a bit Comment 0 of this Bug.
Comment 8 Ludek Smid 2014-06-13 05:39:59 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.