Bug 980559 - Doc for nova: some packages are not installed but used
Doc for nova: some packages are not installed but used
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Installation_and_Configuration_Guide (Show other bugs)
3.0
Unspecified Unspecified
high Severity high
: async
: 3.0
Assigned To: Stephen Gordon
ecs-bugs
: Documentation, Triaged, ZStream
: 985036 (view as bug list)
Depends On:
Blocks: 1011085
  Show dependency treegraph
 
Reported: 2013-07-02 13:32 EDT by Attila Darazs
Modified: 2014-01-05 23:25 EST (History)
3 users (show)

See Also:
Fixed In Version: Red_Hat_OpenStack-Installation_and_Configuration_Guide-3-web-en-US-3-30.el6eng
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build: CSProcessor Builder Version 1.10 Build Name: 15807, Installation and Configuration Guide-3-1 Build Date: 01-07-2013 17:33:39 Topic ID: 15952-465697 [Latest]
Last Closed: 2014-01-05 23:25:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Attila Darazs 2013-07-02 13:32:05 EDT
Title: Installing the Compute Service

Describe the issue:
In a later chapter ("10.3.6. Starting the Compute Services") the documentation instructs to start the api, scheduler and conductor services, but they are not installed at any point in the guide.

[root@localhost etc(keystone_admin)]# service openstack-nova-api start
openstack-nova-api: unrecognized service

Suggestions for improvement:
Add the "openstack-nova-api openstack-nova-scheduler openstack-nova-conductor" packages to the yum install line to this chapter, and maybe also a short description about them, as it is in the other parts of the doc.
Comment 2 Stephen Gordon 2013-07-16 11:39:39 EDT
*** Bug 985036 has been marked as a duplicate of this bug. ***
Comment 3 Stephen Gordon 2013-07-17 11:35:37 EDT
Added API, Conductor, and Scheduler services to yum install instructions.

"Installing the Compute Service" - ID: 15952 [rev: 478987]
"Installing the Compute Service" - ID: 15952 [rev: 478988]

Note You need to log in before you can comment on or make changes to this bug.