Bug 980565 - Dashboard docs: nova service restart command
Dashboard docs: nova service restart command
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Installation_and_Configuration_Guide (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 4.0
Assigned To: Stephen Gordon
ecs-bugs
: Documentation
Depends On:
Blocks: 1011085
  Show dependency treegraph
 
Reported: 2013-07-02 13:52 EDT by Attila Darazs
Modified: 2013-09-24 13:56 EDT (History)
2 users (show)

See Also:
Fixed In Version: Red_Hat_OpenStack-Installation_and_Configuration_Guide-3-en-US-3-29
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build: CSProcessor Builder Version 1.10 Build Name: 15807, Installation and Configuration Guide-3-1 Build Date: 01-07-2013 17:33:39 Topic ID: 15858-469723 [Latest]
Last Closed: 2013-07-24 15:14:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Attila Darazs 2013-07-02 13:52:25 EDT
Title: Configuring Database Session Storage

Describe the issue:
 Restart the nova-api service to ensure the API server can connect to the Dashboard and to avoid an error displayed in the Dashboard.

#service restart nova-api

Suggestions for improvement:
The correct command is

# service openstack-nova-api restart

Additional information:

Also I'm not sure if the mysql part in the 4th step should create a user as 'dash'@'localhost', instead or next to the 'dash'@'%' user. The other parts of the documentation are doing this.
Comment 2 Stephen Gordon 2013-07-02 14:15:07 EDT
(In reply to Attila Darazs from comment #0)
> Title: Configuring Database Session Storage
> 
> Describe the issue:
>  Restart the nova-api service to ensure the API server can connect to the
> Dashboard and to avoid an error displayed in the Dashboard.
> 
> #service restart nova-api
> 
> Suggestions for improvement:
> The correct command is
> 
> # service openstack-nova-api restart

This bit is covered off under Bug # 975419.

> Additional information:
> 
> Also I'm not sure if the mysql part in the 4th step should create a user as
> 'dash'@'localhost', instead or next to the 'dash'@'%' user. The other parts
> of the documentation are doing this.

This I think is an issue, in particular because we create 'dash'@'%' but then use localhost as the hostname for local_settings.py. I don't believe that would work because the '%' wildcard does not include the socket based connection created in this case. I think the correct / best approach is to be consistent with the rest of the docs and create both the '%' and 'localhost' grant.

There is also some leading space in the screen element for step 7:

# cd /usr/share/openstack-dashboard
                    #python manage.py syncdb

https://access.redhat.com/site/documentation/en-US/Red_Hat_OpenStack/3/html/Installation_and_Configuration_Guide/Configuring_Database_Session_Storage.html

Given the minor nature of the required changes I will take it for a 3.0.z update.
Comment 3 Stephen Gordon 2013-07-02 14:34:39 EDT
"Configuring Database Session Storage" - ID: 15858 [rev: 473583]

Note You need to log in before you can comment on or make changes to this bug.