Bug 980576 - DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist
DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "Get" with si...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:0807c0ab057839ba39d7732d133...
:
: 1007358 (view as bug list)
Depends On:
Blocks: F20FinalBlocker
  Show dependency treegraph
 
Reported: 2013-07-02 14:32 EDT by Sebastian Pölsterl
Modified: 2013-09-18 22:40 EDT (History)
11 users (show)

See Also:
Fixed In Version: anaconda-20.17-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 22:40:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (519.46 KB, text/plain)
2013-07-02 14:33 EDT, Sebastian Pölsterl
no flags Details
File: anaconda.log (6.55 KB, text/plain)
2013-07-02 14:33 EDT, Sebastian Pölsterl
no flags Details
File: environ (518 bytes, text/plain)
2013-07-02 14:33 EDT, Sebastian Pölsterl
no flags Details
File: lsblk_output (2.96 KB, text/plain)
2013-07-02 14:33 EDT, Sebastian Pölsterl
no flags Details
File: messages (187.51 KB, text/plain)
2013-07-02 14:33 EDT, Sebastian Pölsterl
no flags Details
File: nmcli_dev_list (7.08 KB, text/plain)
2013-07-02 14:33 EDT, Sebastian Pölsterl
no flags Details
File: os_info (179 bytes, text/plain)
2013-07-02 14:33 EDT, Sebastian Pölsterl
no flags Details
File: program.log (56.67 KB, text/plain)
2013-07-02 14:33 EDT, Sebastian Pölsterl
no flags Details
File: storage.log (193.49 KB, text/plain)
2013-07-02 14:33 EDT, Sebastian Pölsterl
no flags Details
File: ifcfg.log (573 bytes, text/plain)
2013-07-02 14:33 EDT, Sebastian Pölsterl
no flags Details

  None (edit)
Description Sebastian Pölsterl 2013-07-02 14:32:57 EDT
Description of problem:
Selected German in installer and pressed next.

Version-Release number of selected component:
anaconda-19.30.13-1.fc19.x86_64

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 81, in getNMObjProperty
    property)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 963, in _add_ap
    mode = getNMObjProperty(ap_dbus, ".AccessPoint", "Mode")
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 818, in _refresh_ap
    self._add_ap(ap, active)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 702, in refresh_ui
    self._refresh_ap(device, state)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 385, in on_device_selection_changed
    self.refresh_ui(device)
DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist


Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:UUID=6A57-F544 rootfstype=vfat ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: dbus-python-1.1.1-5.fc19.x86_64
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19
Comment 1 Sebastian Pölsterl 2013-07-02 14:33:07 EDT
Created attachment 767895 [details]
File: anaconda-tb
Comment 2 Sebastian Pölsterl 2013-07-02 14:33:11 EDT
Created attachment 767896 [details]
File: anaconda.log
Comment 3 Sebastian Pölsterl 2013-07-02 14:33:14 EDT
Created attachment 767897 [details]
File: environ
Comment 4 Sebastian Pölsterl 2013-07-02 14:33:18 EDT
Created attachment 767898 [details]
File: lsblk_output
Comment 5 Sebastian Pölsterl 2013-07-02 14:33:23 EDT
Created attachment 767899 [details]
File: messages
Comment 6 Sebastian Pölsterl 2013-07-02 14:33:28 EDT
Created attachment 767900 [details]
File: nmcli_dev_list
Comment 7 Sebastian Pölsterl 2013-07-02 14:33:32 EDT
Created attachment 767901 [details]
File: os_info
Comment 8 Sebastian Pölsterl 2013-07-02 14:33:36 EDT
Created attachment 767902 [details]
File: program.log
Comment 9 Sebastian Pölsterl 2013-07-02 14:33:42 EDT
Created attachment 767903 [details]
File: storage.log
Comment 10 Sebastian Pölsterl 2013-07-02 14:33:46 EDT
Created attachment 767904 [details]
File: ifcfg.log
Comment 11 David Shea 2013-09-05 13:36:23 EDT
*** Bug 1001776 has been marked as a duplicate of this bug. ***
Comment 12 Radek Vykydal 2013-09-10 03:58:20 EDT
Not fixed yet.
Comment 13 Fedora Update System 2013-09-11 21:02:49 EDT
anaconda-20.15-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.15-1.fc20
Comment 14 Kamil Páral 2013-09-12 07:01:06 EDT
*** Bug 1007358 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2013-09-12 12:27:05 EDT
Package anaconda-20.15-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.15-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16519/anaconda-20.15-1.fc20
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2013-09-13 21:04:38 EDT
anaconda-20.16-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.16-1.fc20
Comment 17 Fedora Update System 2013-09-16 13:47:28 EDT
anaconda-20.17-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.17-1.fc20
Comment 18 Fedora Update System 2013-09-18 22:40:15 EDT
anaconda-20.17-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.