Bug 980862 - [engine] The column name call_stack was not found in this ResultSet
[engine] The column name call_stack was not found in this ResultSet
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.3.0
Assigned To: Oved Ourfali
infra
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 07:34 EDT by Aharon Canan
Modified: 2016-02-10 14:14 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 08:40:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (2.78 MB, text/plain)
2013-07-03 07:34 EDT, Aharon Canan
no flags Details

  None (edit)
Description Aharon Canan 2013-07-03 07:34:39 EDT
Created attachment 768207 [details]
engine.log

Description of problem:
GUI is trying to load for long time without Success
Checked the logs, I see there "bad SQL grammar" in loop, not sure if this is the root cause

2013-07-03 14:22:46,337 ERROR [org.ovirt.engine.core.bll.SearchQuery] (ajp-/127.0.0.1:8702-8) Query SearchQuery failed. Exception message is StatementCallback; bad SQL grammar [SELECT * FROM (SELECT * FROM audit_log WHERE ( audit_log_id > 0 and audit_log_id IN (SELECT audit_log.audit_log_id FROM  audit_log  ) and not deleted)  ORDER BY audit_log_id DESC ,audit_log_id DESC ) as T1 OFFSET (1 -1) LIMIT 100]; nested exception is org.postgresql.util.PSQLException: The column name call_stack was not found in this ResultSet.


Version-Release number of selected component (if applicable):
3.3 (is4)

How reproducible:
100%

Steps to Reproduce:
1. install is4
2. enter webadmin using "admin" (using workaround from bug 980858)
3. try to create new data center

Actual results:
GUi trying to load without success, after trying to create DC GUI gets stuck

Expected results:
GUi should work properly 

Additional info:
Comment 1 Einav Cohen 2013-07-19 15:48:20 EDT
sounds related to bug 966198 (infra) -> moving to infra.
Oved - any idea?
Comment 2 Oved Ourfali 2013-07-21 02:17:07 EDT
Proper upgrade/new installation should have created this field.
Was there any failures in the DB upgrade?
Comment 3 Barak 2013-07-21 06:04:54 EDT
Aharon,

A few questions:
- was this on an upgraded system ? (probably yes).
- From what version to what version was it upgraded ?
- Can you please provide the upgrade logs & yum log ?
Comment 4 Aharon Canan 2013-07-21 06:11:42 EDT
- I am not sure about the upgrade and versions, as it was not part of the upgrade I didn't give it attention 
also, the system was deleted few times since then so no upgrade logs...
Comment 5 Oved Ourfali 2013-08-01 08:23:15 EDT
I cannot reproduce this bug.
Does it reproduce for you in latest build?
If not I suggest we close this bug.
Comment 6 Aharon Canan 2013-08-01 08:38:36 EDT
I didn't face it again since then,
let's close and I will reopen in case needed.

Note You need to log in before you can comment on or make changes to this bug.