Bug 981689 - 'SubscribeCommand' object has no attribute 'sorter'
'SubscribeCommand' object has no attribute 'sorter'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: Carter Kozak
IDM QE LIST
: Regression
: 982370 (view as bug list)
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-07-05 09:35 EDT by John Sefler
Modified: 2014-09-14 20:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:12:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2013-07-05 09:35:06 EDT
Description of problem:
subscribe is throwing this traceback

[root@jsefler-5server ~]# tail -f /var/log/rhsm/rhsm.log

2013-07-05 09:29:09,809 [ERROR]  @managercli.py:149 - Unable to attach: 'SubscribeCommand' object has no attribute 'sorter'
2013-07-05 09:29:09,810 [ERROR]  @managercli.py:150 - 'SubscribeCommand' object has no attribute 'sorter'
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 1465, in _do_command
    self.sorter.force_cert_check()
AttributeError: 'SubscribeCommand' object has no attribute 'sorter'


Version-Release number of selected component (if applicable):
[root@jsefler-5server ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.16-1
subscription-manager: 1.8.11-1.git.49.2f10c8a.el5
python-rhsm: 1.8.13-1.git.0.85d7af5.el5


How reproducible:


Steps to Reproduce:
[root@jsefler-5server ~]# subscription-manager register --username testuser1 --password password --org admin
The system has been registered with ID: c3a1a0f8-1ab2-411b-ba07-f963ebd650a2
[root@jsefler-5server ~]# subscription-manager list --avail | grep ID | tail -1
Pool ID:           8a90f81a3fab8113013fab82a5af053c
[root@jsefler-5server ~]# subscription-manager subscribe --pool 8a90f81a3fab8113013fab82a5af053c
Successfully attached a subscription for: Awesome OS Instance Based (Standard Support)
'SubscribeCommand' object has no attribute 'sorter'
[root@jsefler-5server ~]#
Comment 1 RHEL Product and Program Management 2013-07-05 09:38:14 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 John Sefler 2013-07-06 13:49:06 EDT
Here's another occurrence of the same error:

subscription-manager attach --pool=123
Stdout: Subscription pool 123 does not exist.
Stderr: 'AttachCommand' object has no attribute 'sorter'
ExitCode: 255
Comment 4 Carter Kozak 2013-07-08 10:35:47 EDT
commit 86e53c3b4c79f6938762b8f56388feeb80ea0f1c
Author: ckozak <ckozak@redhat.com>
Date:   Mon Jul 8 09:22:33 2013 -0400

    981689: fix attach command
Comment 5 Carter Kozak 2013-07-08 16:20:05 EDT
*** Bug 982370 has been marked as a duplicate of this bug. ***
Comment 8 Shwetha Kallesh 2013-07-15 02:58:19 EDT
Marking verified!!

[root@localhost ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.16-1
subscription-manager: 1.8.13-1.el5
python-rhsm: 1.8.13-1.git.0.85d7af5.el5



[root@localhost ~]# subscription-manager register --username testuser1 --password password --org admin --force
The system with UUID e88ab74a-147d-4c70-8fee-1ee270c8ce0f has been unregistered
The system has been registered with ID: 3fddfb99-eca1-432a-b814-5a06302444fe 
[root@localhost ~]# subscription-manager list --avail | grep ID | tail -1
Pool ID:           8ac6a3a23fbcb162013fbcb271bd08a7
[root@localhost ~]# subscription-manager attach --pool 8ac6a3a23fbcb162013fbcb271bd08a7
Successfully attached a subscription for: Awesome OS Server Basic (data center)


[root@localhost ~]# tail -f /var/log/rhsm/rhsm.log
2013-07-15 12:25:12,718 [DEBUG]  @connection.py:613 - Server supports the following resources:
2013-07-15 12:25:12,718 [DEBUG]  @connection.py:614 - {'': '/', 'hypervisors': '/hypervisors', 'serials': '/serials', 'deleted_consumers': '/deleted_consumers', 'consumers': '/consumers', 'migrations': '/migrations', 'content': '/content', 'entitlements': '/entitlements', 'statistics/generate': '/statistics/generate', 'status': '/status', 'jobs': '/jobs', 'users': '/users', 'subscriptions': '/subscriptions', 'rules': '/rules', 'distributor_versions': '/distributor_versions', 'consumertypes': '/consumertypes', 'activation_keys': '/activation_keys', 'atom': '/atom', 'owners': '/owners', 'roles': '/roles', 'admin': '/admin', 'events': '/events', 'products': '/products', 'pools': '/pools', 'crl': '/crl'}
2013-07-15 12:25:12,718 [INFO]  @cache.py:338 - Server does not support packages, skipping profile upload.
2013-07-15 12:25:12,718 [DEBUG]  @injection.py:80 - Returning instance for feature PROD_DIR
2013-07-15 12:25:12,733 [INFO]  @cache.py:165 - Checking current system info against cache: /var/lib/rhsm/cache/installed_products.json
2013-07-15 12:25:12,733 [INFO]  @cache.py:182 - No changes.
2013-07-15 12:25:12,733 [DEBUG]  @connection.py:394 - Loading CA PEM certificates from: /etc/rhsm/ca/
2013-07-15 12:25:12,734 [DEBUG]  @connection.py:376 - Loading CA certificate: '/etc/rhsm/ca/candlepin-ca.pem'
2013-07-15 12:25:12,734 [DEBUG]  @connection.py:376 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2013-07-15 12:25:12,734 [DEBUG]  @connection.py:376 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2013-07-15 12:25:12,734 [DEBUG]  @connection.py:376 - Loading CA certificate: '/etc/rhsm/ca/10.pem'
2013-07-15 12:25:12,734 [DEBUG]  @connection.py:415 - Making request: POST /candlepin/consumers/3fddfb99-eca1-432a-b814-5a06302444fe/entitlements?pool=8ac6a3a23fbcb162013fbcb271bd08a7
2013-07-15 12:25:12,881 [DEBUG]  @connection.py:434 - Response status: 200
2013-07-15 12:25:12,882 [INFO]  @managercli.py:1431 - Successfully attached a subscription for: Awesome OS Server Basic (data center) (8ac6a3a23fbcb162013fbcb271bd08a7)
2013-07-15 12:25:12,882 [DEBUG]  @injection.py:80 - Returning instance for feature ENT_DIR
2013-07-15 12:25:12,883 [DEBUG]  @connection.py:394 - Loading CA PEM certificates from: /etc/rhsm/ca/
2013-07-15 12:25:12,883 [DEBUG]  @connection.py:376 - Loading CA certificate: '/etc/rhsm/ca/candlepin-ca.pem'
2013-07-15 12:25:12,883 [DEBUG]  @connection.py:376 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2013-07-15 12:25:12,884 [DEBUG]  @connection.py:376 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2013-07-15 12:25:12,884 [DEBUG]  @connection.py:376 - Loading CA certificate: '/etc/rhsm/ca/10.pem'
2013-07-15 12:25:12,884 [DEBUG]  @connection.py:415 - Making request: GET /candlepin/consumers/3fddfb99-eca1-432a-b814-5a06302444fe/certificates/serials
2013-07-15 12:25:12,938 [DEBUG]  @connection.py:434 - Response status: 200
2013-07-15 12:25:12,939 [DEBUG]  @injection.py:80 - Returning instance for feature ENT_DIR
2013-07-15 12:25:12,940 [DEBUG]  @connection.py:394 - Loading CA PEM certificates from: /etc/rhsm/ca/
2013-07-15 12:25:12,940 [DEBUG]  @connection.py:376 - Loading CA certificate: '/etc/rhsm/ca/candlepin-ca.pem'
2013-07-15 12:25:12,940 [DEBUG]  @connection.py:376 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2013-07-15 12:25:12,940 [DEBUG]  @connection.py:376 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2013-07-15 12:25:12,940 [DEBUG]  @connection.py:376 - Loading CA certificate: '/etc/rhsm/ca/10.pem'
2013-07-15 12:25:12,941 [DEBUG]  @connection.py:415 - Making request: GET /candlepin/consumers/3fddfb99-eca1-432a-b814-5a06302444fe/certificates?serials=2288177557642831081
2013-07-15 12:25:12,994 [DEBUG]  @connection.py:434 - Response status: 200
2013-07-15 12:25:12,995 [INFO]  @certlib.py:243 - certs updated:
Total updates: 1
Found (local) serial# []
Expected (UEP) serial# [2288177557642831081]
Added (new)
  [sn:2288177557642831081 (Awesome OS Server Basic (data center)) @ /etc/pki/entitlement/2288177557642831081.pem]
Deleted (rogue):
  <NONE>
2013-07-15 12:25:13,118 [DEBUG]  @injection.py:54 - Registering provider for feature IDENTITY: <class 'subscription_manager.identity.Identity'>
2013-07-15 12:25:13,118 [DEBUG]  @injection.py:54 - Registering provider for feature PRODUCT_DATE_RANGE_CALCULATOR: <function factory at 0x2abda4f01140>
2013-07-15 12:25:13,118 [DEBUG]  @injection.py:54 - Registering provider for feature ENT_DIR: <class 'subscription_manager.certdirectory.EntitlementDirectory'>
2013-07-15 12:25:13,118 [DEBUG]  @injection.py:54 - Registering provider for feature PROD_DIR: <class 'subscription_manager.certdirectory.ProductDirectory'>
2013-07-15 12:25:13,118 [DEBUG]  @injection.py:54 - Registering provider for feature STATUS_CACHE: <class 'subscription_manager.cache.StatusCache'>
2013-07-15 12:25:13,118 [DEBUG]  @injection.py:54 - Registering provider for feature PROD_STATUS_CACHE: <class 'subscription_manager.cache.ProductStatusCache'>
2013-07-15 12:25:13,118 [DEBUG]  @injection.py:54 - Registering provider for feature CP_PROVIDER: <class 'subscription_manager.cp_provider.CPProvider'>
2013-07-15 12:25:13,118 [DEBUG]  @injection.py:54 - Registering provider for feature CERT_SORTER: <class 'subscription_manager.cert_sorter.CertSorter'>
2013-07-15 12:25:13,118 [DEBUG]  @injection.py:54 - Registering provider for feature PLUGIN_MANAGER: <class 'subscription_manager.plugins.PluginManager'>
2013-07-15 12:25:13,119 [DEBUG]  @injection.py:54 - Registering provider for feature DBUS_IFACE: <class 'subscription_manager.utils.DbusIface'>
2013-07-15 12:25:13,121 [INFO]  @rhsmd:194 - rhsmd started
2013-07-15 12:25:13,123 [INFO]  @rhsmd:151 - D-Bus interface com.redhat.SubscriptionManager.EntitlementStatus.check_status called
2013-07-15 12:25:13,161 [DEBUG]  @injection.py:72 - Initializing singleton for feature CERT_SORTER
2013-07-15 12:25:13,161 [DEBUG]  @injection.py:72 - Initializing singleton for feature CP_PROVIDER
2013-07-15 12:25:13,161 [DEBUG]  @injection.py:80 - Returning instance for feature CP_PROVIDER
2013-07-15 12:25:13,161 [DEBUG]  @injection.py:72 - Initializing singleton for feature PROD_DIR
2013-07-15 12:25:13,162 [DEBUG]  @injection.py:80 - Returning instance for feature PROD_DIR
2013-07-15 12:25:13,162 [DEBUG]  @injection.py:72 - Initializing singleton for feature ENT_DIR
2013-07-15 12:25:13,162 [DEBUG]  @injection.py:80 - Returning instance for feature ENT_DIR
2013-07-15 12:25:13,162 [DEBUG]  @injection.py:72 - Initializing singleton for feature IDENTITY
2013-07-15 12:25:13,162 [DEBUG]  @identity.py:130 - Loading consumer info from identity certificates.
2013-07-15 12:25:13,163 [DEBUG]  @injection.py:80 - Returning instance for feature IDENTITY
2013-07-15 12:25:13,163 [DEBUG]  @injection.py:80 - Returning instance for feature PROD_DIR
2013-07-15 12:25:13,177 [DEBUG]  @profile.py:96 - Loading current RPM profile.
2013-07-15 12:25:13,266 [INFO]  @connection.py:583 - Using certificate authentication: key = /etc/pki/consumer/key.pem, cert = /etc/pki/consumer/cert.pem, ca = /etc/rhsm/ca/, insecure = False
2013-07-15 12:25:13,266 [INFO]  @connection.py:596 - Connection Built: host: 10.70.35.34, port: 8443, handler: /candlepin
2013-07-15 12:25:13,266 [INFO]  @cache.py:165 - Checking current system info against cache: /var/lib/rhsm/cache/installed_products.json
2013-07-15 12:25:13,267 [INFO]  @cache.py:182 - No changes.
2013-07-15 12:25:13,267 [DEBUG]  @certdirectory.py:204 - Installed product IDs: ['100000000000060', '1000000000000023', '100000000000011', '27060', '1', '37069', '37068', '37080', '37065', '37067', '37060', '37062', '100000000000006', '100000000000005', '100000000000002', '100000000000003', '100000000000000', '100000000000001', '213412341236', '213412341237', '213412341234', '213412341235', '100000000000020', '32060', '88888', '100000000000069', '900', '917571', '801', '806', '37070']
2013-07-15 12:25:13,267 [DEBUG]  @injection.py:72 - Initializing singleton for feature STATUS_CACHE
2013-07-15 12:25:13,267 [DEBUG]  @injection.py:80 - Returning instance for feature STATUS_CACHE
2013-07-15 12:25:13,267 [DEBUG]  @connection.py:394 - Loading CA PEM certificates from: /etc/rhsm/ca/
2013-07-15 12:25:13,268 [DEBUG]  @connection.py:376 - Loading CA certificate: '/etc/rhsm/ca/candlepin-ca.pem'
2013-07-15 12:25:13,268 [DEBUG]  @connection.py:376 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2013-07-15 12:25:13,268 [DEBUG]  @connection.py:376 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2013-07-15 12:25:13,268 [DEBUG]  @connection.py:376 - Loading CA certificate: '/etc/rhsm/ca/10.pem'
2013-07-15 12:25:13,269 [DEBUG]  @connection.py:415 - Making request: GET /candlepin/consumers/3fddfb99-eca1-432a-b814-5a06302444fe/compliance
2013-07-15 12:25:13,327 [DEBUG]  @connection.py:434 - Response status: 200
2013-07-15 12:25:13,329 [DEBUG]  @cache.py:138 - Wrote cache: /var/lib/rhsm/cache/entitlement_status.json
2013-07-15 12:25:13,331 [DEBUG]  @cert_sorter.py:254 - valid entitled products: []
2013-07-15 12:25:13,331 [DEBUG]  @cert_sorter.py:255 - expired entitled products: []
2013-07-15 12:25:13,332 [DEBUG]  @cert_sorter.py:256 - partially entitled products: []
2013-07-15 12:25:13,332 [DEBUG]  @cert_sorter.py:257 - unentitled products: ['100000000000060', '1000000000000023', '100000000000011', '27060', '1', '37069', '37068', '213412341237', '37065', '37067', '37060', '37062', '100000000000006', '100000000000005', '100000000000002', '100000000000003', '100000000000000', '100000000000001', '213412341236', '100000000000069', '213412341234', '213412341235', '100000000000020', '32060', '88888', '900', '917571', '37080', '801', '806', '37070']
2013-07-15 12:25:13,332 [DEBUG]  @cert_sorter.py:258 - future products: []
2013-07-15 12:25:13,332 [DEBUG]  @cert_sorter.py:259 - partial stacks: []
2013-07-15 12:25:13,332 [DEBUG]  @cert_sorter.py:260 - entitlements valid until: 2013-07-15 06:59:28+00:00
2013-07-15 12:25:13,332 [DEBUG]  @injection.py:80 - Returning instance for feature CERT_SORTER
2013-07-15 12:25:13,332 [INFO]  @rhsmd:134 - D-Bus signal com.redhat.SubscriptionManager.EntitlementStatus.entitlement_status_changed emitted
Comment 10 errata-xmlrpc 2013-09-30 19:12:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.