Bug 982370 - sub-man subscribe throws error when used to subscribe more than one pool
sub-man subscribe throws error when used to subscribe more than one pool
Status: CLOSED DUPLICATE of bug 981689
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-07-08 16:13 EDT by Sharath Dwaral
Modified: 2015-03-22 21:14 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 16:20:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error log (32.19 KB, text/plain)
2013-07-08 16:13 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description Sharath Dwaral 2013-07-08 16:13:13 EDT
Created attachment 770653 [details]
error log

Description of problem:
subscribe command throws an error when used to subscribe more than one pool at the same time

Version-Release number of selected component (if applicable):
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-firstboot-1.8.11-1.git.51.c749cd2.el5
python-rhsm-1.8.13-1.git.0.85d7af5.el5
python-rhsm-debuginfo-1.8.12-1.el5
subscription-manager-1.8.11-1.git.51.c749cd2.el5
subscription-manager-migration-data-1.11.3.1-1.git.1.78afd75.el5
subscription-manager-debuginfo-1.8.11-1.el5
subscription-manager-gui-1.8.11-1.git.51.c749cd2.el5
subscription-manager-migration-1.8.11-1.git.51.c749cd2.el5

How reproducible:
Always

Steps to Reproduce:

1. Register to candlepin server

2. Subscribe to multiple pools

# subscription-manager subscribe --pool 8a90f8333fbce2a8013fbce4339a0937 --pool 8a90f8333fbce2a8013fbce432b108e9
Successfully attached a subscription for: Awesome OS Modifier
Successfully attached a subscription for: Awesome OS Server Basic
'SubscribeCommand' object has no attribute 'sorter'

# echo $?
255

Actual results:
stdout: 'SubscribeCommand' object has no attribute 'sorter' in standard out and stderr: 255

Expected results:
stdout: should not display the above error message
stderr: should be 0

Additional info:
Comment 1 Carter Kozak 2013-07-08 16:20:05 EDT
This was fixed this morning.

*** This bug has been marked as a duplicate of bug 981689 ***

Note You need to log in before you can comment on or make changes to this bug.