Bug 982286 - Removing a subscription through GUI doesn't always show Confirmation string in dialog
Removing a subscription through GUI doesn't always show Confirmation string i...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-07-08 11:07 EDT by Matt Reid
Modified: 2013-09-30 19:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:12:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Remove subscription confirmation dialog, with no string (55.65 KB, image/png)
2013-07-08 11:08 EDT, Matt Reid
no flags Details
remove subscription with '&' (79.65 KB, image/png)
2013-08-07 13:11 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description Matt Reid 2013-07-08 11:07:11 EDT
Description of problem:
Not sure what to attribute this to, but currently I'm registered with Stage as user '2013sku', and have two subscriptions attached to my system, 'RHEL Server Premium (8 sockets) (up to 4 guests)' and 'RHEL Server Premium with Smart Management & Resilient Storage'.

Clicking remove from the My Subscriptions tab and trying to remove RHEL Server (8 sockets) works as expected, but trying to remove the one with Smart Management shows an empty confirmation dialog, with no string inside it, just the icon and the buttons.

Version-Release number of selected component (if applicable):
latest sub-man, built from git today after seeing it on whatever I had built last week

How reproducible:
I saw it on my system and Cory was able to reproduce

Steps to Reproduce:
1. register with stage as user 2013sku
2. attach the two subscriptions mentioned above, or at least RHEL w/ smart management
3. Try to remove RHEL w/ smart management

Actual results:
no confirmation string shows in the dialog

Expected results:
See the "Are you sure you wish to remove sub X?" string in the dialog

Additional info:
Stage has been wonky for me lately, with intermittent connectivity issues, but I don't think this string comes from the server, maybe it does though. Possible that stage is the culprit for this, I'm not sure if the smart management sku is in prod or not to see if its an environment or sku issue, or an issue with how the string is called or something.
Comment 1 Matt Reid 2013-07-08 11:08:00 EDT
Created attachment 770540 [details]
Remove subscription confirmation dialog, with no string
Comment 2 RHEL Product and Program Management 2013-07-08 11:17:58 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 Cory Scheviak 2013-07-15 12:15:12 EDT
The issue that was occurring here resulted from an '&' character in the name of a subscription to be parsed as markup (eg: an html tag) instead of being parsed verbatim as a string name.

Fixed originally here:
09d9ee14fe9d19fb3b7a04ae73c9999805afb825 and afffee4006216add0566c93d8984ad61b4ec6cd3

Unfortunately, this was too broad of a location to tell the program to parse verbatim as a string, and it ended up getting rid of all parsing whatsover, causing bold text to be read as <b>text</b> instead of the word text in bold font.

Fixed this and finally solved issue here:
a8754eeb7529679113c0ed54cbd7c61d7b45df8b
Comment 5 Jesus M. Rodriguez 2013-07-18 15:49:28 EDT
Moving back to post commit a8754eeb7529679113c0ed54cbd7c61d7b45df8b didn't make the 1.8.13 tag. Will be in the next build.
Comment 8 Jesus M. Rodriguez 2013-08-06 10:46:44 EDT
*** Bug 986803 has been marked as a duplicate of this bug. ***
Comment 9 Sharath Dwaral 2013-08-07 13:11:02 EDT
Created attachment 783999 [details]
remove subscription with '&'

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-gui-1.8.18-1.el5
subscription-manager-migration-data-1.11.3.2-1.git.0.14f9d59.el5
python-rhsm-1.8.16-1.el5
subscription-manager-migration-1.8.18-1.el5
subscription-manager-1.8.18-1.el5
subscription-manager-firstboot-1.8.18-1.el5
python-rhsm-debuginfo-1.8.16-1.el5
subscription-manager-debuginfo-1.8.18-1.el5

Removing subscription with '&' works fine (see attachment)

VERIFIED
Comment 12 errata-xmlrpc 2013-09-30 19:12:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.