Bug 985139 - [RFE] Total disk quota for glance users
[RFE] Total disk quota for glance users
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance (Show other bugs)
4.0
Unspecified Unspecified
low Severity unspecified
: z1
: 4.0
Assigned To: Flavio Percoco
Dafna Ron
https://blueprints.launchpad.net/glan...
: FutureFeature, ZStream
: 890209 (view as bug list)
Depends On: 988544 1043929
Blocks: RHOS50RFE
  Show dependency treegraph
 
Reported: 2013-07-16 18:34 EDT by John Bresnahan
Modified: 2016-04-26 22:03 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-glance-2013.2.1-3.el6ost
Doc Type: Enhancement
Doc Text:
A feature has been added which provides basic quotas support for OpenStack Image service (Glance). A storage quota has been added that is applied against the sum total of a user's storage consumption, across all configured storage systems. A single quota is applied to all users via the configuration option 'total_storage_quota'.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 09:24:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 37993 None None None Never

  None (edit)
Comment 2 John Bresnahan 2013-07-26 16:21:23 EDT
*** Bug 890209 has been marked as a duplicate of this bug. ***
Comment 3 John Bresnahan 2013-07-26 16:47:44 EDT
There is an upstream review here: https://review.openstack.org/#/c/37993/
Comment 4 John Bresnahan 2013-08-29 15:03:41 EDT
Upstream patch has merged: https://review.openstack.org/#/c/37993/
Comment 10 Perry Myers 2013-12-17 09:51:46 EST
(In reply to Tzach Shefi from comment #9)
> Check the RFE was not able to verify due to belwo bugs:
> 
> 1. https://bugzilla.redhat.com/show_bug.cgi?id=1043929
> 
> 2. https://bugzilla.redhat.com/show_bug.cgi?id=1043952
> 
> 3. https://bugzilla.redhat.com/show_bug.cgi?id=1043954

I see the above three bugs.  Did this feature (the current bug) not work *at all* or did it work, but there were three follow on bugs.

If this feature mostly worked, and there were a few follow on bugs (3), then this feature should be moved to VERIFIED and we'll address the follow on bugs in 4.0.z and 5.0

If the feature in its entirety did not work, in any situation, please let me know.  In that case this bug should stay ASSIGNED but I do not see it as a release blocker regardless.
Comment 14 Dafna Ron 2014-01-20 10:47:27 EST
I only did a few tests, not enough to fully cover RFE tests.

Feature is implemented, few bugs opened. 

https://bugzilla.redhat.com/show_bug.cgi?id=1055491
https://bugzilla.redhat.com/show_bug.cgi?id=1055522
https://bugzilla.redhat.com/show_bug.cgi?id=1055550

moving to verified based on current implementation for openstack-glance-2013.2.1-3.el6ost.noarch

[root@cougar07 tmp(keystone_admin)]# glance image-create --name file --disk-format  qcow2 --container-format bare --file /tmp/2e8d93c1-286a-409e-ab68-aa448e8ef086 
Request returned failure status.
413 Request Entity Too Large
Denying attempt to upload image because it exceeds the .quota: The size of the data 10737418240 will exceed the limit. -6442450943 bytes remaining.
    (HTTP 413)
Comment 17 Lon Hohberger 2014-02-04 12:20:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-0046.html

Note You need to log in before you can comment on or make changes to this bug.