Bug 98595 - Puts file in /usr/lib64 on i386
Summary: Puts file in /usr/lib64 on i386
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: pkgconfig   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords: Triaged
: 97384 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-07-04 12:09 UTC by Alexander Larsson
Modified: 2007-04-18 16:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-23 21:46:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexander Larsson 2003-07-04 12:09:23 UTC
On my i386 install containing gtk-doc-1.1-1 I have the file
/usr/lib64/pkgconfig/gtk-doc.pc. I guess this is because this is a noarch
package, and it happened to be built on a lib64 machine.

Its not immediately obvious what the right solution is here though.. moving it
ot /usr/lib will break x86-64.

Comment 1 Alexander Larsson 2003-07-04 12:14:24 UTC
Possible choices seem to be: 
* store the .pc in both lib and lib64
* don't make the package noarch

Comment 2 Owen Taylor 2003-07-04 14:05:21 UTC
Another possibility, that I'd be interested in hearing's hp's take on:

 - Make pkgconfig also search /usr/share/pkgconfig
 - Put the .pc file there

Comment 3 Havoc Pennington 2003-07-04 14:41:10 UTC
Seems reasonable, though I can imagine people using datadir when they shouldn't.
(Just because their .pc file happens to not look arch-specific at the moment,
rather than a plainly noarch package)

Would need to sort out how it relates to PKG_CONFIG_PATH

Comment 4 Miloslav Trmac 2003-07-04 17:33:23 UTC
*** Bug 97384 has been marked as a duplicate of this bug. ***

Comment 5 Alexander Larsson 2003-08-13 11:34:57 UTC
I think we need to solve this soon. Otherwise won't it start to create problems
when we build packages using the new gtk-doc.make stuff?

Comment 6 Owen Taylor 2003-08-28 20:42:27 UTC
I think the PKG_CONFIG_PATH relationship is simply that you have
to list both directories in PKG_CONFIG_PATH if you want both searched.
Maybe we could have something like

 PKG_CONFIG_PATH=/usr/local/@

and have that automatically expand to:

 PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/local/share/pkgconfig

Filed gtk-doc bug upstream as:

 http://bugzilla.gnome.org/show_bug.cgi?id=120950

I can't file a pkg-config bug upstream since there is no bugzilla for it.

* Thu Aug 28 2003 Owen Taylor <otaylor@redhat.com> 1.1-3.0
- Move gtk-doc.pc file to %{_datadir}/pkgconfig (#98595)
- Require: /usr/bin/cmp (#88763, Thomas Vander Stichele)
- Added libxslt docbook-style-xsl to Require: and BuildPrereq
  (#99143, Ken MacFarlane)

I don't think this should affect our building much - very few things
require gtk-doc at build time. (Nothing should - everything should
be distributed with the built HTML docs, but there may be exceptions.)


Comment 7 Owen Taylor 2003-08-28 20:43:25 UTC
It should be noted that this applies both for RHL and RHEL, since 
1.1 is in both trees.


Comment 8 Dave Habben 2003-10-22 14:44:19 UTC
Verified as fixed in the latest release, suggesting that this be marked as
RAWHIDE/CLOSED

$ rpm -q gtk-doc
gtk-doc-1.1-3.1

$ rpm -ql gtk-doc | grep gtk-doc.pc
/usr/share/pkgconfig/gtk-doc.pc

$ rpm -q gtk-doc --changelog | head
* Thu Aug 28 2003 Owen Taylor <otaylor@redhat.com> 1.1-3.0

- Move gtk-doc.pc file to /usr/share/pkgconfig (#98595)


Comment 9 Owen Taylor 2003-10-22 15:44:01 UTC
No, this bug is very much not fixed; the gtk-doc part is there, but
the pkgconfig part is not; the file is in /usr/share/pkgconfig, but
won't be found.


Comment 10 Owen Taylor 2003-10-23 21:46:59 UTC
* Thu Oct 23 2003 Owen Taylor <otaylor@redhat.com> 1:0.14.0-6
- Make pkgconfig look in /usr/share/pkgconfig as well by default (#98595)

(Note that I *didn't* build this into the RHEL 3 updates tree, since
it's something of a semantic change, and I don't think compiling gtk-doc
using applications from source is going to be a big usage of RHEL 3.)


Comment 11 Alexander Larsson 2004-01-19 12:14:42 UTC
I did this for gnome-icon-theme.pc too.



Note You need to log in before you can comment on or make changes to this bug.