This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 985953 - [RFE] Volume migration
[RFE] Volume migration
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
4.0
Unspecified Unspecified
high Severity medium
: ---
: 4.0
Assigned To: Eric Harney
Yogev Rabl
https://blueprints.launchpad.net/cind...
upstream_milestone_none upstream_stat...
: FutureFeature, TestOnly
Depends On:
Blocks: RHOS40RFE 1045054 1056108
  Show dependency treegraph
 
Reported: 2013-07-18 11:06 EDT by Eric Harney
Modified: 2016-04-26 11:09 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-cinder-2013.2-0.9.b3.el6ost
Doc Type: Enhancement
Doc Text:
A feature has been added to OpenStack Block Storage which allows migrating a block storage volume from one backend to another. This is an admin-only interface used for manually invoking volume migration. It is useful for manual tuning and scripting.
Story Points: ---
Clone Of:
: 988443 1045054 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:13:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 33055 None None None Never
OpenStack gerrit 37685 None None None Never

  None (edit)
Description Eric Harney 2013-07-18 11:06:56 EDT
This work will add an admin-only interface to manually invoke volume migration - "I want to move this volume to that specific backend". This is useful for manual tuning and scripting.

This initial version will be the simplest case - a detached volume with no snapshots. A later blueprint will handle cases of attached volumes and volumes with snapshots. Attaching/detaching during migration will not be allowed for now.

https://blueprints.launchpad.net/cinder/+spec/volume-migration
Comment 12 Yogev Rabl 2013-11-17 07:04:26 EST
The verification of the RFE is blocked by Bug 1031010 .
Comment 17 errata-xmlrpc 2013-12-19 19:13:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.