This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 988443 - [Doc] [RFE] Volume migration
[Doc] [RFE] Volume migration
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Administration_User_Guide (Show other bugs)
4.0
Unspecified Unspecified
low Severity low
: ---
: 4.0
Assigned To: Summer Long
ecs-bugs
https://blueprints.launchpad.net/cind...
upstream_milestone_none upstream_stat...
: Documentation, FutureFeature, Triaged
Depends On:
Blocks: 1011085
  Show dependency treegraph
 
Reported: 2013-07-25 11:27 EDT by Stephen Gordon
Modified: 2016-04-26 14:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 985953
Environment:
Last Closed: 2014-01-05 22:37:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 33055 None None None Never
OpenStack gerrit 37685 None None None Never

  None (edit)
Description Stephen Gordon 2013-07-25 11:27:51 EDT
+++ This bug was initially created as a clone of Bug #985953 +++

This work will add an admin-only interface to manually invoke volume migration - "I want to move this volume to that specific backend". This is useful for manual tuning and scripting.

This initial version will be the simplest case - a detached volume with no snapshots. A later blueprint will handle cases of attached volumes and volumes with snapshots. Attaching/detaching during migration will not be allowed for now.

https://blueprints.launchpad.net/cinder/+spec/volume-migration
Comment 2 Summer Long 2013-08-12 20:26:36 EDT
Hi Eric, looks like you're the dev for this one. The following provides a lot of how it should work:https://etherpad.openstack.org/havana-cinder-volume-migration

But I can't see what the user needs to do to migrate a volume. Is it just on the command line? Or in the Dashboard? If so, how?

And how to use volume_type or volume_retype?

thanks, Summer
Comment 3 Eric Harney 2013-08-27 17:00:26 EDT
There is a cinder client operation 'migrate' which is being added for this (still pending merge upstream):

$ cinder migrate <volume> <host> --force-host-copy=True|False

https://review.openstack.org/#/c/37685/3/cinderclient/v2/shell.py
Comment 4 Summer Long 2013-09-25 20:44:33 EDT
Upstream doc bug: 
https://bugs.launchpad.net/openstack-manuals/+bug/1201555
Comment 5 Summer Long 2013-10-02 02:21:07 EDT
Eric, that change was merged on Sep.15th, and I have a python-cinderclient that was built on the 20th (python-cinderclient.noarch  1.0.5-2.el6). The problem is that the 'migrate' option isn't showing up. 
So, can you tell me whether this is still the solution? Or is there a newer package I should be using to look at the CLI?
thanks, Summer
Comment 6 Eric Harney 2013-10-02 17:02:50 EDT
(In reply to Summer Long from comment #5)
> Eric, that change was merged on Sep.15th, and I have a python-cinderclient
> that was built on the 20th (python-cinderclient.noarch  1.0.5-2.el6). The
> problem is that the 'migrate' option isn't showing up. 

You will need cinderclient 1.0.6, which has not been released yet.  It should be released upstream within the next few days, and then packaged downstream not too long after that.  Sorry about that.
Comment 7 Summer Long 2013-10-16 02:49:04 EDT
Made change upstream: https://review.openstack.org/52016
Eric, can you please review upstream? many thanks, Summer

Note You need to log in before you can comment on or make changes to this bug.