Bug 986079 - sandbox -X does nothing at all after F19 upgrade
sandbox -X does nothing at all after F19 upgrade
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 18:26 EDT by Andy Lutomirski
Modified: 2013-10-08 07:25 EDT (History)
5 users (show)

See Also:
Fixed In Version: policycoreutils-2.1.14-46.6.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 07:25:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Lutomirski 2013-07-18 18:26:53 EDT
I upgraded to F19, and sandbox -X appears to be completely broken.


$ sandbox -X echo foo
$ sandbox -X echo foo
$ sandbox -X gnome-terminal
$ sandbox -X sleep 10

All of those commands exit quickly and have no apparent effect.  audit.log, dmesg, and journalctl show nothing.  strace suggests that the seunshare command is returning with exit code 255.  (But strace may interfere with seunshare, so this could be entirely meaninglyss.)

Relabeling /, /tmp, and (recursively) my home directory had no effect.
Comment 1 Daniel Walsh 2013-07-19 06:55:41 EDT
You need to grab the latest X package.

I think it is 

xorg-x11-server-Xorg-1.14.2-5

Xephyr dropped the -resizable flag which is causing the breakage.

You could also remove this option from /usr/share/sandbox/sandboxX.sh for now.
Comment 2 Eric Seynaeve 2013-07-20 05:31:32 EDT
Thanks for the information Daniel. I was hit with the same issue.

I have disabled the option in the mentioned shell script and it's working OK now.

At least the window doesn't look like an alien app in KDE anymore ;-)

Eric
Comment 3 Dimitris 2013-09-24 12:58:06 EDT
This is broken again, but removing -resizable from /usr/share/sandbox/sandboxX.sh is not having any effect.

> [d@gaspode tmp]$ sandbox echo foo
> foo
> [d@gaspode tmp]$ sandbox -X echo foo
> [d@gaspode tmp]$ 

policycoreutils.x86_64                       2.1.14-46.5.fc19
policycoreutils-devel.x86_64                 2.1.14-46.5.fc19
policycoreutils-gui.x86_64                   2.1.14-46.5.fc19
policycoreutils-python.x86_64                2.1.14-46.5.fc19
policycoreutils-sandbox.x86_64               2.1.14-46.5.fc19
xorg-x11-server-Xephyr.x86_64                1.14.3-1.fc19

Nothing in journal, dmesg, audit, no selinux alerts.
Comment 4 Daniel Walsh 2013-09-24 15:35:12 EDT

*** This bug has been marked as a duplicate of bug 1011588 ***
Comment 5 Daniel Walsh 2013-09-29 08:05:59 EDT
*** Bug 1013273 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2013-10-04 15:08:03 EDT
policycoreutils-2.1.14-46.6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/policycoreutils-2.1.14-46.6.fc19
Comment 7 Fedora Update System 2013-10-05 21:36:00 EDT
Package policycoreutils-2.1.14-46.6.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing policycoreutils-2.1.14-46.6.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18394/policycoreutils-2.1.14-46.6.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-10-08 07:25:15 EDT
policycoreutils-2.1.14-46.6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.