Bug 986155 - Punjabi (India) missing in language installation list
Punjabi (India) missing in language installation list
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: langtable (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike FABIAN
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks: 986944
  Show dependency treegraph
 
Reported: 2013-07-19 01:33 EDT by Pravin Satpute
Modified: 2013-09-12 04:27 EDT (History)
12 users (show)

See Also:
Fixed In Version: langtable-0.0.13-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 986944 (view as bug list)
Environment:
Last Closed: 2013-09-11 22:00:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[F19] screenshot showing Punjabi (Pakistan) as the only choice for Punjabi (88.86 KB, image/png)
2013-07-19 02:21 EDT, Steve Tyler
no flags Details
[F18] screenshot showing Punjabi (India) as the only choice for Punjabi (94.98 KB, image/png)
2013-07-19 02:32 EDT, Steve Tyler
no flags Details

  None (edit)
Description Pravin Satpute 2013-07-19 01:33:26 EDT
Description of problem:
Punjabi (India) not available for installation. It was there earlier. Looks like regression.

Please note Punjabi (Pakistani)  and Punjabi (India) differs lot. 

Version-Release number of selected component (if applicable):
anaconda-19.30.13-1.fc19.x86_64

How reproducible:
everytime

Steps to Reproduce:
1. Try to select Punjabi (India) language for installation
2.
3.

Actual results:
Punjabi (India) not available

Expected results:
It should be there in installation list

Additional info:
This is Regression issue.
Comment 1 Steve Tyler 2013-07-19 02:21:49 EDT
Created attachment 775645 [details]
[F19] screenshot showing Punjabi (Pakistan) as the only choice for Punjabi

Tested with:
$ qemu-kvm -m 4096 -hda f19-test-2.img -cdrom ~/xfr/fedora/F19/Fedora-19-x86_64-DVD.iso -vga std -boot menu=on
Comment 2 Steve Tyler 2013-07-19 02:32:33 EDT
Created attachment 775649 [details]
[F18] screenshot showing Punjabi (India) as the only choice for Punjabi

Tested with:
$ qemu-kvm -m 4096 -hda f18-test-4.img -cdrom ~/xfr/fedora/F18/Fedora-18-x86_64-DVD.iso -vga std -boot menu=on
Comment 3 Steve Tyler 2013-07-19 02:37:00 EDT
Could you confirm that _both_ should be in the list?
Punjabi (India)
Punjabi (Pakistan)
Comment 4 Pravin Satpute 2013-07-19 03:27:39 EDT
yes. 

The way we have English for number of countries, we have Punjabi also for India and Pakistan :)
Comment 5 Parag Nemade 2013-07-19 03:30:47 EDT
Not sure what went wrong when we start using langtable.
Comment 6 Fedora Update System 2013-07-30 08:20:33 EDT
langtable-0.0.8-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/langtable-0.0.8-1.fc19
Comment 7 Mike FABIAN 2013-07-30 08:39:13 EDT
*** Bug 986658 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2013-08-01 23:41:40 EDT
Package langtable-0.0.8-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing langtable-0.0.8-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14003/langtable-0.0.8-1.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-08-04 01:28:16 EDT
langtable-0.0.9-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/langtable-0.0.9-1.fc19
Comment 10 Fedora Update System 2013-08-13 10:54:36 EDT
langtable-0.0.10-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/langtable-0.0.10-1.fc19
Comment 11 Fedora Update System 2013-08-19 03:05:55 EDT
langtable-0.0.11-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/langtable-0.0.11-1.fc19
Comment 12 Steve Tyler 2013-08-27 19:11:52 EDT
(In reply to Steve Tyler from comment #3)
> Could you confirm that _both_ should be in the list?
> Punjabi (India)
> Punjabi (Pakistan)

There is only one Punjabi translation (with language code "pa") in transifex:[1]

Panjabi (Punjabi)
https://fedora.transifex.com/projects/p/fedora/language/pa/?project=2059

There are, however, locales for both:[2]

$ rpm -ql glibc-common | grep pa_
/usr/share/i18n/locales/pa_IN
/usr/share/i18n/locales/pa_PK

Can the same translation be used for both?

[1] All translations can be listed in alphabetical order here:
https://fedora.transifex.com/projects/p/fedora/

[2] Checked in F19 and F20:
$ rpm -q glibc-common
glibc-common-2.17-13.fc19.x86_64

$ cat /usr/share/i18n/locales/pa_IN | egrep 'language|territory'
% Punjabi language locale for Indian Punjabi(Gurmukhi)
title      "Punjabi language locale for Indian Punjabi(Gurmukhi)"
language   "Punjabi"
territory  "India"

$ cat /usr/share/i18n/locales/pa_PK | egrep 'language|territory'
language   "Punjabi (Shahmukhi)"
territory  "Pakistan"
Comment 13 Parag Nemade 2013-08-27 22:55:43 EDT
No. You can see only pa_IN locale is getting updated translations to almost all the active upstream projects. But I don't think someone is contributing to pa_PK locale translations. Both locales are using different scripts. See
http://en.wikipedia.org/wiki/Gurmukhī_alphabet
http://en.wikipedia.org/wiki/Shahmukh%C4%AB_alphabet

As there are no translation for pa_PK in anaconda Punajbi(Pakistan) will not get displayed in language selection list.
Comment 14 Steve Tyler 2013-08-28 00:23:36 EDT
(In reply to Parag from comment #13)
> No. You can see only pa_IN locale is getting updated translations to almost
> all the active upstream projects. But I don't think someone is contributing
> to pa_PK locale translations. Both locales are using different scripts. See
> http://en.wikipedia.org/wiki/Gurmukhī_alphabet
> http://en.wikipedia.org/wiki/Shahmukh%C4%AB_alphabet
> 
> As there are no translation for pa_PK in anaconda Punajbi(Pakistan) will not
> get displayed in language selection list.

Thanks for your clarifications. That is very helpful.

Pravin in Comment 4 said that both should be listed, but that is clearly not possible if they use different scripts and only pa_IN is being actively translated.
Comment 15 Fedora Update System 2013-08-28 08:01:37 EDT
langtable-0.0.12-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/langtable-0.0.12-1.fc19
Comment 16 Vratislav Podzimek 2013-09-04 07:41:02 EDT
Just an update here -- major changes to the anaconda installer have been done. A preview of the new behaviour can be seen at:
http://vpodzime.fedorapeople.org/locales_changes.webm
Comment 17 Fedora Update System 2013-09-05 06:09:56 EDT
langtable-0.0.13-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/langtable-0.0.13-1.fc19
Comment 18 Fedora Update System 2013-09-11 22:00:46 EDT
langtable-0.0.13-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.