Bug 988018 - [engine-webadmin] user cannot perform any operation under VM tab from the tree pane on UI
[engine-webadmin] user cannot perform any operation under VM tab from the tre...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
x86_64 Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Tomas Jelinek
Pavel Novotny
virt
: Regression
: 988376 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 10:29 EDT by Elad
Modified: 2015-09-22 09 EDT (History)
9 users (show)

See Also:
Fixed In Version: is10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (154.59 KB, image/png)
2013-07-24 10:29 EDT, Elad
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17957 None None None Never
oVirt gerrit 17976 None None None Never

  None (edit)
Description Elad 2013-07-24 10:29:39 EDT
Created attachment 777820 [details]
screenshot

Description of problem:
When user tries to perform operations related to VMs, under 'Virtual Machines' tab, while being on the tree pane of the relevant DC on UI, like creating a new VM, the window gets stuck.


Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.9.master.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. stand on a specific DC on the tree pane (on the left side of UI)
2. try to create a new VM
3.

Actual results:
The new VM window creation gets stuck


Additional info:
screenshot
Comment 3 Einav Cohen 2013-08-01 08:35:19 EDT
Elad: When standing on a Data-Center in the left-pane tree: Are you able to perform actions (that involve a dialog) from main tabs other than the VMs one?

[i.e. When standing on a Data-Center in the left-pane tree: Are you able to add a new Cluster from the Clusters main tab, add a new Host from the Hosts main tab, add a new Storage Domain from the Storage main tab, etc.]?

If the VMs main tab seems to be like the only problem - please change the Whiteboard of this BZ from 'infra' to 'virt'. Thanks.
Comment 4 Elad 2013-08-01 08:40:49 EDT
(In reply to Einav Cohen from comment #3)
> Elad: When standing on a Data-Center in the left-pane tree: Are you able to
> perform actions (that involve a dialog) from main tabs other than the VMs
> one?
yes, only VM operations fail
> [i.e. When standing on a Data-Center in the left-pane tree: Are you able to
> add a new Cluster from the Clusters main tab, add a new Host from the Hosts
> main tab, add a new Storage Domain from the Storage main tab, etc.]?
 yes
> If the VMs main tab seems to be like the only problem - please change the
> Whiteboard of this BZ from 'infra' to 'virt'. Thanks.
changed
Comment 5 Michal Skrivanek 2013-08-09 10:18:39 EDT
*** Bug 988376 has been marked as a duplicate of this bug. ***
Comment 6 Einav Cohen 2013-08-09 10:26:58 EDT
please note the specific quota-related scenario described in the duplicate bug 988376 and make sure that it is covered as well. thanks.
Comment 10 Tomas Jelinek 2013-08-13 02:44:35 EDT
merged: 187616e7cef9d9d57e3cff0c6cfae1a798ccb89b
Comment 11 Barak Dagan 2013-08-18 14:53:25 EDT
Please note that bug https://bugzilla.redhat.com/show_bug.cgi?id=986862 is duplicate of bug https://bugzilla.redhat.com/show_bug.cgi?id=988376 which is duplicate of this one, therefore need to make sure that it's scenario is covered as well. thanks.
Comment 12 Pavel Novotny 2013-09-05 11:56:42 EDT
Verified in rhevm-3.3.0-0.19.master.el6ev.noarch (is13).

VM operations work properly, such as create & edit VM, create from template, make template, run/suspend/shutdown.

Scenario with VM quota as is decribed in bug 988376 also ended up successfully.
Comment 13 Itamar Heim 2014-01-21 17:20:40 EST
Closing - RHEV 3.3 Released
Comment 14 Itamar Heim 2014-01-21 17:26:18 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.