Bug 988376 - When quota is created in disabled mode, quota checkbox for creating vm is not showed when dc is switch to enforced/audit mode.
When quota is created in disabled mode, quota checkbox for creating vm is not...
Status: CLOSED DUPLICATE of bug 988018
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Tomas Jelinek
Pavel Stehlik
virt
: Triaged
: 986862 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 08:48 EDT by Ondra Machacek
Modified: 2015-09-22 09 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-09 10:18:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondra Machacek 2013-07-25 08:48:41 EDT
Description of problem:
If user create quota when dc is in disabled quota mode, then quota checkbox don't appers in new vm dialog when dc quota mode is switched into audit/enforced mode.

Version-Release number of selected component (if applicable):
is6

How reproducible:
always

Steps to Reproduce:
1. Create dc and set quota mode to disabled.
2. In tree view select the dc. Go to Quota main tab.
3. Create new quota.
4. Set dc to audit/enforced mode.
5. Try to create vm.

Actual results:
User can't set quota for vm, because there is no quota section.

Expected results:
1) Delete quota main tab when quota mode is disabled.
or
2) User should be able to set quota of vm, even when the quota was created in disabled mode.

Additional info:
When quota is created in audit/enforced mode, everything works as expected.
Comment 1 Doron Fediuck 2013-07-29 10:03:10 EDT
This may be related to recent UI changes in this dialog.

Einav, can you please check and update if this is a regression due to recent changes?
Comment 2 Einav Cohen 2013-08-07 12:35:05 EDT
reply to Doron Fediuck from comment #1)
> This may be related to recent UI changes in this dialog.
> 
> Einav, can you please check and update if this is a regression due to recent
> changes?

Hi Doron, I apologize for the late response; I assume that you are referring to the layout changes introduced as part of the instance types feature; putting 'needinfo' on Tomas, which is probably most familiar with this dialog in any case, so he will be able to assist you.
Comment 3 Tomas Jelinek 2013-08-08 04:22:14 EDT
Hi,

it should not be related to that changes - the quota field was just moved not directly changed. I was not able to simulate this, I can imagine that it has something to do with the gwt upgrade which caused some mysterious behavior similar to this one which is afaik fixed. Or it can be similar to 985813
which I was able to simulate. So if I find out what the issue is in 985813 maybe it helps me to do also something about the quota...
Comment 4 Einav Cohen 2013-08-08 09:26:48 EDT
(In reply to Tomas Jelinek from comment #3)
> Hi,
> 
> it should not be related to that changes - the quota field was just moved
> not directly changed. I was not able to simulate this, I can imagine that it
> has something to do with the gwt upgrade which caused some mysterious
> behavior similar to this one which is afaik fixed. Or it can be similar to
> 985813
> which I was able to simulate. So if I find out what the issue is in 985813
> maybe it helps me to do also something about the quota...

Hi Tomas, note that this bz has been opened on is6 (which was released on July 17), whereas the gwt upgrade patch was merged only on July 22, so this issue has nothing to do with the gwt upgrade.

@Ondra - can you please re-test the behavior with one of the recent builds (e.g. is9) to see if this behavior is still reproducible (it seems that Tomas cannot reproduce it)?
Comment 5 Ondra Machacek 2013-08-08 09:38:02 EDT
I've retested on is9 and the quota combobox for vm don't appear only when user 
have selected specific DC in tree view, when user have selected 'System' in tree 
view quota combobox is showed(in audit/enforced mode).
Comment 6 Tomas Jelinek 2013-08-08 09:43:45 EDT
ok, now I have simulated it as well.
Comment 7 Einav Cohen 2013-08-08 10:23:25 EDT
There is a similar bug (bug 988018) which also describes problems in the VM dialog when a DC is selected on the left-pane tree.
@Michal - maybe makes sense to move this BZ to 'virt'?
Comment 8 Michal Skrivanek 2013-08-09 10:18:39 EDT

*** This bug has been marked as a duplicate of bug 988018 ***
Comment 9 Einav Cohen 2013-08-16 17:29:03 EDT
*** Bug 986862 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.