Bug 988538 - [Doc] [RFE] Transfer ownership of volumes
[Doc] [RFE] Transfer ownership of volumes
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Administration_User_Guide (Show other bugs)
4.0
Unspecified Unspecified
high Severity high
: ---
: 4.0
Assigned To: Summer Long
ecs-bugs
https://wiki.openstack.org/wiki/Volum...
: Documentation, FutureFeature, Triaged
Depends On:
Blocks: 985458 1011085
  Show dependency treegraph
 
Reported: 2013-07-25 15:20 EDT by Stephen Gordon
Modified: 2014-01-05 22:37 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-05 22:37:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cinder client transfer operations (4.33 KB, text/plain)
2013-10-14 11:24 EDT, Eric Harney
no flags Details
cinder client transfer operations (4.39 KB, text/plain)
2013-10-14 11:26 EDT, Eric Harney
no flags Details

  None (edit)
Description Stephen Gordon 2013-07-25 15:20:22 EDT
Cloned for documentation impact, refer to Bug # 985458 for implementation details.
Comment 2 Summer Long 2013-08-06 02:08:33 EDT
Support transferring of Cinder volume ownership from one customer to another.

Hi Eric,
Viewing upstream, it looks as though this is only a command-line functionality, and won't be available in the Dashboard. Is that correct? Can you provide the procedure/command?

thanks, Summer
Comment 3 Eric Harney 2013-08-11 12:36:58 EDT
It's not clear to me that there is even CLI functionality for this yet.  Maybe nothing user-visible for Havana.
Comment 4 Summer Long 2013-08-11 19:08:24 EDT
Ok, will have to wait and see what happens upstream. https://review.openstack.org/#/c/29227/
Comment 5 Summer Long 2013-09-25 21:12:34 EDT
Lon, can you say what the user impact here is? Looks like only the 29227 change was made, and per Eric that looks solely backend? thanks, Summer
Comment 6 Summer Long 2013-10-14 01:51:20 EDT
Eric, I probably should have sent this straight over to you. Can you say what the user impact is? thanks, Summer
Comment 7 Eric Harney 2013-10-14 11:24:22 EDT
Created attachment 812089 [details]
cinder client transfer operations

Example commands run with cinder client.  This demonstrates creating a transfer operation and accepting it.
Comment 8 Eric Harney 2013-10-14 11:26:40 EDT
Created attachment 812090 [details]
cinder client transfer operations
Comment 9 Summer Long 2013-10-14 23:38:33 EDT
Raised upstream bug: https://bugs.launchpad.net/openstack-manuals/+bug/1239920
Comment 10 Summer Long 2013-10-15 00:08:25 EDT
Changes made: https://review.openstack.org/51775
Eric, I added you in as the dev reviewer. Many thanks for the attachment, that was great. :) Summer
Comment 12 Yogev Rabl 2013-11-25 08:48:59 EST
Can you please elaborate about the volume accept procedure: 
as you can see here: Bug 1033926
Comment 13 Summer Long 2013-11-25 18:20:36 EST
The new bug https://bugzilla.redhat.com/show_bug.cgi?id=1033926 will handle the updates, have switched its component to the End User Guide. Thanks for the questions, Yogev.

Note You need to log in before you can comment on or make changes to this bug.