Bug 989498 - vzfs missing in hrStorage in an Virtuozzo Container
vzfs missing in hrStorage in an Virtuozzo Container
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: net-snmp (Show other bugs)
6.4
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jan Safranek
Dalibor Pospíšil
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 07:42 EDT by Andreas Schnederle-Wagner
Modified: 2013-11-21 17:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In the previous net-snmp updates, the implementation of “HOST-RESOURCES-MIB::hrStorageTable” was rewritten and devices with Virtuozzo File System (VZFS) and BTRFS were not reported. In this update, snmpd properly recognizes VZFS and BTRFS devices and reports them in “HOST-RESOURCES-MIB::hrStorageTable”.
Story Points: ---
Clone Of:
: 1036055 (view as bug list)
Environment:
Last Closed: 2013-11-21 17:50:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 861152 None None None Never

  None (edit)
Description Andreas Schnederle-Wagner 2013-07-29 07:42:55 EDT
Description of problem:
   On RHEL 6.x with default net-snmp package I can't get hrStorage Data with SNMP. So no monitoring of diskspace with nagios/icinga/... is possible.
   It worked on older RHEL 4.x/5.x Version - but also not on the few latest Versions.
   I guess this Bug is related to: https://bugzilla.redhat.com/show_bug.cgi?id=861152

Version-Release number of selected component (if applicable):
   net-snmp-5.5-44.el6_4.2.x86_64

How reproducible:
Query on not working 6.4 Host:
   snmpwalk -v 2c -c public HOST hrStorage
Answer:
   HOST-RESOURCES-MIB::hrStorageType.1 = OID: HOST-RESOURCES-TYPES::hrStorageRam
   HOST-RESOURCES-MIB::hrStorageType.3 = OID: HOST-RESOURCES-TYPES::hrStorageVirtualMemory
   HOST-RESOURCES-MIB::hrStorageType.6 = OID: HOST-RESOURCES-TYPES::hrStorageOther
   HOST-RESOURCES-MIB::hrStorageType.7 = OID: HOST-RESOURCES-TYPES::hrStorageOther
   HOST-RESOURCES-MIB::hrStorageType.10 = OID: HOST-RESOURCES-TYPES::hrStorageVirtualMemory

Query on working 4.9 Host: 
   snmpwalk -v 2c -c public HOST hrStorage
Answer:
   HOST-RESOURCES-MIB::hrStorageType.1 = OID: HOST-RESOURCES-TYPES::hrStorageOther
   HOST-RESOURCES-MIB::hrStorageType.2 = OID: HOST-RESOURCES-TYPES::hrStorageRam
   HOST-RESOURCES-MIB::hrStorageType.3 = OID: HOST-RESOURCES-TYPES::hrStorageVirtualMemory
   HOST-RESOURCES-MIB::hrStorageType.4 = OID: HOST-RESOURCES-TYPES::hrStorageFixedDisk
   HOST-RESOURCES-MIB::hrStorageType.5 = OID: HOST-RESOURCES-TYPES::hrStorageFixedDisk
   HOST-RESOURCES-MIB::hrStorageType.6 = OID: HOST-RESOURCES-TYPES::hrStorageFixedDisk

Additional info:
   hrStorageFixedDisk is missing on current RHEL Versions

   Bug was introduced in RHEL 5.7

   [root@rialtools ~]# df -h
   Filesystem            Size  Used Avail Use% Mounted on
   /dev/vzfs              50G   15G   36G  30% /
   none                  1.0G  4.0K  1.0G   1% /dev
Comment 6 errata-xmlrpc 2013-11-21 17:50:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1693.html

Note You need to log in before you can comment on or make changes to this bug.