Bug 989716 - [Doc] [RFE] Add Rate Limiting Capabilities in Nova Front End Driver
[Doc] [RFE] Add Rate Limiting Capabilities in Nova Front End Driver
Status: CLOSED DUPLICATE of bug 988444
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Administration_User_Guide (Show other bugs)
4.0
Unspecified Unspecified
medium Severity unspecified
: ---
: 4.0
Assigned To: Don Domingo
ecs-bugs
https://blueprints.launchpad.net/nova...
docs-rhos5-ups
: Documentation, FutureFeature
Depends On:
Blocks: 978544 988444
  Show dependency treegraph
 
Reported: 2013-07-29 14:55 EDT by Stephen Gordon
Modified: 2014-03-31 22:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-31 22:21:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2013-07-29 14:55:15 EDT
Cloned for documentation impact, refer to Bug # 978544 for implementation details.
Comment 2 Summer Long 2014-02-10 23:30:41 EST
Hi Russell, can I ask you the same questions that Omri asked in the original bug?
-------------------------------------------

How will the Admin user be able to modify rate-limit for Volume that being attach to instance ? will it be an argument in 'nova volume attach' CLI ? (or via API ? / or configuration file ? ).

will it be possible to change the Instance rate-limit after the volume is already attached to the instance ? or only  during the attach command ?

What command will expose the rate-limit value ? 'cinder show <volume id>' , 'nova show <instance id>'  ?

----------------------------
And would you agree that this info belongs in the Admin Guide, not the Install?

thanks, Summer
Comment 3 Russell Bryant 2014-03-11 11:00:32 EDT
(In reply to Summer Long from comment #2)
> Hi Russell, can I ask you the same questions that Omri asked in the original
> bug?
> -------------------------------------------
> 
> How will the Admin user be able to modify rate-limit for Volume that being
> attach to instance ? will it be an argument in 'nova volume attach' CLI ?
> (or via API ? / or configuration file ? ).
> 
> will it be possible to change the Instance rate-limit after the volume is
> already attached to the instance ? or only  during the attach command ?
> 
> What command will expose the rate-limit value ? 'cinder show <volume id>' ,
> 'nova show <instance id>'  ?

None of the above.  :-)

This feature affects both Nova and Cinder.  There is no visibility into this from the Nova side.  All of the management of the QOS values is done on the Cinder side.

This is the relevant Cinder blueprint, though the contents are pretty useless:

    https://blueprints.launchpad.net/cinder/+spec/pass-ratelimit-info-to-nova

The initial commit message has more information:

    https://review.openstack.org/#/c/29737/

There are some key things from the commit message:

1) These values are not set on a per-volume basis.  It's set globally for a volume type.

2) Management of these values is done via the cinder API, via the "qos_specs_manage" API.  Unfortunately, i can't find any real documentation about this API.

3) The QOS specs are free-form key/value pairs.  Cinder appears to not do any validation.  From looking at the code, I see the following keys can be set when using the libvirt driver in Nova: 'total_bytes_sec', 'read_bytes_sec', 'write_bytes_sec', 'total_iops_sec', 'read_iops_sec', 'write_iops_sec'.  The names effectively describe what limit it provides.  You can set read/write/total limits per second for bytes or iops.

> ----------------------------
> And would you agree that this info belongs in the Admin Guide, not the
> Install?

Yes.
Comment 4 Summer Long 2014-03-12 21:16:22 EDT
Ok, assigning to the Admin Gd and passing it over to Don, 'the Cinder guy'.
Comment 6 Don Domingo 2014-03-27 23:27:23 EDT
actual cinder docs work for this should be covered by BZ#988444. Considering closing this BZ as duplicate.
Comment 7 Don Domingo 2014-03-27 23:54:27 EDT
Setting Russell Bryant as NEEDINFO. 

Russell, I'm already tracking the documentation of "QoS support for volumes" on a different bug: https://bugzilla.redhat.com/show_bug.cgi?id=988444#c5

Does that cover the docs impact of this particular BZ (meaning, I can close this as a duplicate of BZ#988444)? Or was there something else for this BZ?
Comment 8 Russell Bryant 2014-03-28 03:45:06 EDT
Sounds like you can close this one.  You may want to use some of the information I provided in comment #3 though.
Comment 9 Don Domingo 2014-03-31 22:21:14 EDT
Thanks Russell. I've contacted Eric Harney about what QoS spec key pair values are valid (or how to verify validity of values). I'm starting to suspect though that values are driver/vendor specific (ie will still need to be implemented by each volume driver vendor).

*** This bug has been marked as a duplicate of bug 988444 ***

Note You need to log in before you can comment on or make changes to this bug.