Bug 989729 - [Doc] Upgrades from RHOS 3.0 Quantum to RHOS 4.0 Neutron (configuration, database migrations)
[Doc] Upgrades from RHOS 3.0 Quantum to RHOS 4.0 Neutron (configuration, data...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Release_Notes (Show other bugs)
3.0
Unspecified Unspecified
high Severity high
: ---
: 4.0
Assigned To: Summer Long
ecs-bugs
: Documentation
: 989732 (view as bug list)
Depends On:
Blocks: 958568 1011085
  Show dependency treegraph
 
Reported: 2013-07-29 15:32 EDT by Stephen Gordon
Modified: 2014-01-05 22:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-05 22:55:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2013-07-29 15:32:21 EDT
Cloned for documentation impact, refer to Bug # 958568 for implementation details.
Comment 2 Summer Long 2013-10-30 18:53:40 EDT
DO NOT PUT IN FOR BETA RELEASE NOTES, ONLY FOR GA.
Comment 3 Summer Long 2013-11-26 00:24:38 EST
*** Bug 989732 has been marked as a duplicate of this bug. ***
Comment 6 Summer Long 2013-12-14 16:00:17 EST
Moving back to RC, per request from Program Mtg.
Comment 7 Summer Long 2013-12-14 16:03:24 EST
Per Jeff Dexter:
Going off release notes from Grizzly 3.0 I was able to use this path
stop all services
for i in /etc/init.d/quantum-* ; do $i stop ; done
for i in /etc/init.d/openstack-* ; do $i stop ; done

Add channel for Rhos 4
remove channel for Rhos 3
yum upgrade

Sync databases
keystone-manage db_sync
cinder-manage db sync
glance-manage db_sync
nova-manage db sync

neutron-db-manage --config-file /etc/neutron/neutron.conf \
  --config-file /etc/neutron/plugin.ini current
  
neutron-db-manage --config-file /etc/neutron/neutron.conf \
  --config-file /etc/neutron/plugin.ini stamp grizzly
  
  neutron-db-manage --config-file /etc/neutron/neutron.conf \
  --config-file /etc/neutron/plugin.ini upgrade head
  
start services

This worked besides for Horizon failing to start which is documented in BZ 1040688
-----
After going through the upgrade process on a non-allinone test system, it took 40 minutes to do the keystone-manage db_sync.  Should we note that a customers delete expired tokens before starting the database syncs?
Comment 8 Summer Long 2013-12-15 04:04:42 EST
Draft finished and in git. Sanity check and need to do bug-list generation before publishing.
Comment 9 Summer Long 2013-12-15 21:17:42 EST
Deepti has approved sanity check. Waiting for build before moving to QE.

Note You need to log in before you can comment on or make changes to this bug.