Bug 9898 - duplication of bug #4022 - koi2alt may not to be gzipped
Summary: duplication of bug #4022 - koi2alt may not to be gzipped
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: console-tools   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-01 18:23 UTC by Leonid Kanter
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-02 00:22:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Leonid Kanter 2000-03-01 18:23:11 UTC
In 19990829-7 version, koi2alt map is gzipped. but it has not to be
gzipped, because if you type "consolechars -f Cyr_a8x16 -m koi2alt", you'll
see:

Assuming 8-bit font-charset-map - MUST be a regular file

It mean that maps like koi2alt, koi8u2ruscii etc work only in plain text
format, not gzip. Look at bug #4022.

Comment 1 Leonid Kanter 2000-03-01 23:12:59 UTC
ALL 8-bit maps including VITAL koi2alt are broken in this package by .spec
author! Don't strip .trans suffix and don't gzip 8-bit maps! Please remove
following lines from spec file:
------------
for i in $RPM_BUILD_ROOT/usr/lib/kbd/consoletrans/*.trans; do
        NEWNAME=`echo $i |sed -e s/\\\.trans//`
        if [ -e $NEWNAME ]; then
                rm -f $i
        else
                mv -f $i $NEWNAME
        fi
        if [ ! -e $NEWNAME.gz ]; then
                gzip -9f $NEWNAME
        fi
done
-------
look at good spec file I've attached to bug 9908.

Comment 2 Bernhard Rosenkraenzer 2000-03-02 00:22:59 UTC
Thanks, fixed.


Note You need to log in before you can comment on or make changes to this bug.