Bug 990592 - Project - missing operation delete/copy/rename
Project - missing operation delete/copy/rename
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
urgent Severity medium
: ER6
: 6.0.0
Assigned To: Alexandre Porcelli
Marek Baluch
:
: 996467 (view as bug list)
Depends On:
Blocks: 990595
  Show dependency treegraph
 
Reported: 2013-07-31 09:46 EDT by Sona Mala
Modified: 2014-08-06 16:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:19:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sona Mala 2013-07-31 09:46:07 EDT
Description of problem:
Project is unable to delete/copy/rename.
I am not able to find any menu (buttons) which contains these operations.

Version-Release number of selected component (if applicable):
6.0.0 CR1


Expected results:
I am open to any idea, how to do it from GUI. 

For example: 

add menu item "Project" into Perspective menu (same line as "New Item"), which will contain these operations.

OR

Add buttons to Panel menu in "Project Editor"


Additional info:
Is there any reason why "Project Editor" contains dropdown menu "File" even if another assets contains just buttons (icons) of these operations.
Comment 1 Jiri Locker 2013-08-14 04:09:50 EDT
*** Bug 996467 has been marked as a duplicate of this bug. ***
Comment 2 Edson Tirelli 2013-09-16 16:18:57 EDT
Although we agree this is necessary for the final release, the fix for this has some technical challenges that will take time to overcome. 

We suggest to not mark this as a beta blocker as the product can be tested and used even if you can't delete a project using the UI. As a workaround, the project can be deleted externally by using GIT directly.

We will fix this for the final release.
Comment 3 Prakash Aradhya 2013-09-16 21:57:47 EDT
Internal Whiteboard: Beta Blocker → Blocker
Not critical for Beta, but need to address for GA
Comment 7 Edson Tirelli 2013-11-18 15:14:27 EST
Increasing the priority to get it done for the GA.
Comment 9 Marek Baluch 2013-12-21 09:25:24 EST
Verified on ER6.

Note You need to log in before you can comment on or make changes to this bug.