Bug 99280 - unresolved symbols in /kernel/net/bluetooth/cmtp/cmtp.o
Summary: unresolved symbols in /kernel/net/bluetooth/cmtp/cmtp.o
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel   
(Show other bugs)
Version: alpha 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 90940 100897 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-07-16 22:07 UTC by Mike McLean
Modified: 2015-01-04 22:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-30 00:18:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike McLean 2003-07-16 22:07:37 UTC
* Cambridge-re0716.1

Installing kernel-2.4.21-20.1.2024.2.1.nptl.i686.
depmod: *** Unresolved symbols in
/lib/modules/2.4.21-20.1.2024.2.1.nptl/kernel/net/bluetooth/cmtp/cmtp.o
depmod:         attach_capi_driver_R7524378c
depmod:         detach_capi_driver_R1b092860

Comment 1 Gerald Teschl 2003-07-26 13:05:33 UTC
cmtp depends on a module which is in the kernel-unsupported package:

/lib/modules/2.4.21-20.1.2024.2.1.nptl/unsupported/drivers/isdn/avmb1/kernelcapi.o

So installing the kernel-unsupported package is a work around.

BTW, after installing the unsupported package there is another unresolved symbol:

[root@soliton gerald]# depmod -ae
depmod: *** Unresolved symbols in
/lib/modules/2.4.21-20.1.2024.2.1.nptl/unsupported/drivers/atm/he.o
depmod:         pci_pool_create



Comment 2 Bill Nottingham 2003-07-28 21:21:07 UTC
*** Bug 100897 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2003-07-28 21:21:30 UTC
*** Bug 90940 has been marked as a duplicate of this bug. ***

Comment 4 Mike McLean 2003-08-28 22:55:52 UTC
Still seeing in Cambridge-re0828.nightly:

Error(s) installing: kernel 2.4.21 20.1.2024.2.1.nptl i686
depmod: *** Unresolved symbols in
/lib/modules/2.4.21-20.1.2024.2.1.nptl/kernel/net/bluetooth/cmtp/cmtp.o
depmod:         attach_capi_driver_R7524378c
depmod:         detach_capi_driver_R1b092860


Comment 5 Dave Jones 2003-08-28 23:16:20 UTC
Can you retry with the test kernels at 
http://people.redhat.com/davej/cambridge-test/


Comment 6 Féliciano Matias 2003-09-04 01:35:39 UTC
Try with 2.4.21-20.1.2024.2.26.nptl.
depmod: *** Unresolved symbols in
/lib/modules/2.4.21-20.1.2024.2.26.nptl/kernel/net/bluetooth/cmtp/cmtp.o
depmod:         detach_capi_driver_Rf5f7d0de
depmod:         attach_capi_driver_R61677334


Comment 7 Alexandre Oliva 2003-09-04 04:38:31 UTC
Still present in 2.4.22-20.1.2024.2.36.nptl too.

Comment 8 Mike McLean 2003-09-30 00:18:52 UTC
Seems to have disappeared sometime around 09/09 (kernel-2.4.22-1.2040.nptl.i686).
Closing->Rawhide.  


Note You need to log in before you can comment on or make changes to this bug.