Bug 99328 - Evolution crashes when the contact folder is altered.
Summary: Evolution crashes when the contact folder is altered.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: evolution (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
: 101336 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-07-17 18:43 UTC by Alexander Farley
Modified: 2007-04-18 16:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-07 15:40:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
evolution backtrace. (1.46 KB, text/plain)
2003-07-17 19:58 UTC, Alexander Farley
no flags Details
Evolution trace with strace. (28.50 KB, text/plain)
2003-07-17 20:00 UTC, Alexander Farley
no flags Details
Evolution Bug Buddy backtrace (6.84 KB, text/plain)
2003-07-30 22:19 UTC, Alexander Farley
no flags Details
Bug Buddy trace for Evolution crash (5.57 KB, text/plain)
2003-07-30 22:35 UTC, Kyle R Maxwell
no flags Details

Description Alexander Farley 2003-07-17 18:43:29 UTC
Description of problem:
Evolution crashes/ segfaults when a new contact or the information for an old
contact is changed.

Version-Release number of selected component (if applicable):
evolution-1.4.3-3

How reproducible:
Everytime.

Steps to Reproduce:
1.Open evolution.
2.Go to contacts folder.
3.Add a new contact, enter the contact information, and then save the changes.
    
Actual results:
Evolotion crashed with a segfault.

Expected results:
Evolution would not crash.

Additional info:
The contact information is saved, but evolution must be restarted. .

Comment 1 Jeremy Katz 2003-07-17 19:02:11 UTC
Can you attach the backtrace?

Comment 2 Alexander Farley 2003-07-17 19:58:40 UTC
Created attachment 92985 [details]
evolution backtrace.

Here is what comes out when evolution is run from the shell.

Comment 3 Alexander Farley 2003-07-17 20:00:06 UTC
Created attachment 92986 [details]
Evolution trace with strace.

Here is what comes out when strace is run with evolution.

Comment 4 Bill Nottingham 2003-07-30 22:03:48 UTC
*** Bug 101336 has been marked as a duplicate of this bug. ***

Comment 5 Jeremy Katz 2003-07-30 22:10:47 UTC
When it crashes, bug buddy should come up and prompt you to get backtrace
information.  That's what I need to get an idea of what's going on (it works for me)

Comment 6 Alexander Farley 2003-07-30 22:19:39 UTC
Created attachment 93277 [details]
Evolution Bug Buddy backtrace

Interestingly evolution does not always crash when changes are made to a
contact. However, I was able to achieve a crash.

Comment 7 Kyle R Maxwell 2003-07-30 22:35:37 UTC
Created attachment 93278 [details]
Bug Buddy trace for Evolution crash

Comment 8 Kyle R Maxwell 2003-08-07 15:28:46 UTC
Appears to work properly with evolution-1.4.4-3 from rawhide -- at least my old
steps to reproduce don't currently seem to crash it.

Comment 9 Jeremy Katz 2003-08-07 15:40:41 UTC
Okay, closing as fixed.  Reopen if it pops back up.


Note You need to log in before you can comment on or make changes to this bug.