Bug 993916 - 'upgrade' command displays old version numbers in summary, rather than new version numbers
'upgrade' command displays old version numbers in summary, rather than new ve...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 09:11 EDT by Daniel Berrange
Modified: 2013-08-16 19:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: dnf-0.3.11-1.git7d717c7.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-16 19:06:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2013-08-06 09:11:57 EDT
Description of problem:
I have libvirt 1.0.5.4 installed, and asked dnf to upgrade me to latest version (which is 1.0.5.5). In the summary screen dnf displays, it showed me the version numbers of the currently installed (old) versions, rather than the version numbers of the updates it was about to install.

# dnf --enablerepo=updates-testing update libvirt-client
Setting up Upgrade Process
Resolving Dependencies
--> Starting dependency resolution
---> Package libvirt-client.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt-client.x86_64 1.0.5.5-1.fc19 will be an upgrade
---> Package libvirt-daemon.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt-daemon.x86_64 1.0.5.5-1.fc19 will be an upgrade
---> Package libvirt.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt.x86_64 1.0.5.5-1.fc19 will be an upgrade
---> Package libvirt-daemon-qemu.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt-daemon-qemu.x86_64 1.0.5.5-1.fc19 will be an upgrade
---> Package libvirt-daemon-lxc.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt-daemon-lxc.x86_64 1.0.5.5-1.fc19 will be an upgrade
---> Package libvirt-daemon-kvm.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt-daemon-kvm.x86_64 1.0.5.5-1.fc19 will be an upgrade
---> Package libvirt-daemon-driver-xen.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt-daemon-driver-xen.x86_64 1.0.5.5-1.fc19 will be an upgrade
---> Package libvirt-daemon-driver-uml.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt-daemon-driver-uml.x86_64 1.0.5.5-1.fc19 will be an upgrade
---> Package libvirt-daemon-driver-storage.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt-daemon-driver-storage.x86_64 1.0.5.5-1.fc19 will be an upgrade
---> Package libvirt-daemon-driver-secret.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt-daemon-driver-secret.x86_64 1.0.5.5-1.fc19 will be an upgrade
---> Package libvirt-daemon-driver-qemu.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt-daemon-driver-qemu.x86_64 1.0.5.5-1.fc19 will be an upgrade
---> Package libvirt-daemon-driver-nwfilter.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt-daemon-driver-nwfilter.x86_64 1.0.5.5-1.fc19 will be an upgrade
---> Package libvirt-daemon-driver-nodedev.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt-daemon-driver-nodedev.x86_64 1.0.5.5-1.fc19 will be an upgrade
---> Package libvirt-daemon-driver-network.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt-daemon-driver-network.x86_64 1.0.5.5-1.fc19 will be an upgrade
---> Package libvirt-daemon-driver-lxc.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt-daemon-driver-lxc.x86_64 1.0.5.5-1.fc19 will be an upgrade
---> Package libvirt-daemon-driver-libxl.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt-daemon-driver-libxl.x86_64 1.0.5.5-1.fc19 will be an upgrade
---> Package libvirt-daemon-driver-interface.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt-daemon-driver-interface.x86_64 1.0.5.5-1.fc19 will be an upgrade
---> Package libvirt-daemon-config-nwfilter.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt-daemon-config-nwfilter.x86_64 1.0.5.5-1.fc19 will be an upgrade
---> Package libvirt-daemon-config-network.x86_64 1.0.5.4-1.fc19 will be upgraded
---> Package libvirt-daemon-config-network.x86_64 1.0.5.5-1.fc19 will be an upgrade
--> Finished dependency resolution

Dependencies Resolved

==================================================================================================================================================
 Package                                            Arch                      Version                            Repository                  Size
==================================================================================================================================================
Upgrading:
 libvirt-client                                     x86_64                    1.0.5.4-1.fc19                     @System                     20 M
 libvirt-daemon                                     x86_64                    1.0.5.4-1.fc19                     @System                    4.5 M
 libvirt                                            x86_64                    1.0.5.4-1.fc19                     @System                      0  
 libvirt-daemon-qemu                                x86_64                    1.0.5.4-1.fc19                     @System                      0  
 libvirt-daemon-lxc                                 x86_64                    1.0.5.4-1.fc19                     @System                      0  
 libvirt-daemon-kvm                                 x86_64                    1.0.5.4-1.fc19                     @System                      0  
 libvirt-daemon-driver-xen                          x86_64                    1.0.5.4-1.fc19                     @System                    226 k
 libvirt-daemon-driver-uml                          x86_64                    1.0.5.4-1.fc19                     @System                    115 k
 libvirt-daemon-driver-storage                      x86_64                    1.0.5.4-1.fc19                     @System                    192 k
 libvirt-daemon-driver-secret                       x86_64                    1.0.5.4-1.fc19                     @System                     76 k
 libvirt-daemon-driver-qemu                         x86_64                    1.0.5.4-1.fc19                     @System                    919 k
 libvirt-daemon-driver-nwfilter                     x86_64                    1.0.5.4-1.fc19                     @System                    159 k
 libvirt-daemon-driver-nodedev                      x86_64                    1.0.5.4-1.fc19                     @System                     93 k
 libvirt-daemon-driver-network                      x86_64                    1.0.5.4-1.fc19                     @System                    126 k
 libvirt-daemon-driver-lxc                          x86_64                    1.0.5.4-1.fc19                     @System                    219 k
 libvirt-daemon-driver-libxl                        x86_64                    1.0.5.4-1.fc19                     @System                    197 k
 libvirt-daemon-driver-interface                    x86_64                    1.0.5.4-1.fc19                     @System                     93 k
 libvirt-daemon-config-nwfilter                     x86_64                    1.0.5.4-1.fc19                     @System                    6.1 k
 libvirt-daemon-config-network                      x86_64                    1.0.5.4-1.fc19                     @System                      0  

Transaction Summary
==================================================================================================================================================
Upgrade  19 Packages

Total download size: 8.6 M
Is this ok [y/N]: y
Downloading Packages:


Version-Release number of selected component (if applicable):
dnf-0.3.8-2.git85524ae.fc19.noarch

How reproducible:
Not attempted to reproduce with other packages

Steps to Reproduce:
1. Make sure you have libvirt-client 1.0.5.4 installed (from current updates)
2. Run 'dnf --enablerepo=updates-testing update libvirt-client'
3.

Actual results:
List of packages after resolving deps shows old version numbers

Expected results:
List of packages after resolving deps shows new version numbers


Additional info:
Comment 1 Ales Kozumplik 2013-08-06 09:42:09 EDT
Hello, thanks for the report.

This is related to bug 977753 and bug 968157. The particular issue you are describing was fixed by commit aaa91aa last week and the versions will appear fine in the upcoming DNF build.
Comment 2 Fedora Update System 2013-08-13 06:47:35 EDT
dnf-0.3.11-1.git7d717c7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dnf-0.3.11-1.git7d717c7.fc19
Comment 3 Fedora Update System 2013-08-14 22:34:01 EDT
Package dnf-0.3.11-1.git7d717c7.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.3.11-1.git7d717c7.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14693/dnf-0.3.11-1.git7d717c7.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-08-16 19:06:00 EDT
dnf-0.3.11-1.git7d717c7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.