Bug 994590 - system-config-abrt fails to change abrt settings
system-config-abrt fails to change abrt settings
Status: CLOSED DUPLICATE of bug 993592
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 10:41 EDT by Michael Catanzaro
Modified: 2016-11-30 19:44 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-08 11:20:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Catanzaro 2013-08-07 10:41:37 EDT
Description of problem: This may or may not have been addressed by the fix to Bug #993591, but it's a separate issue: system-config-abrt ("Problem Reporting Configuration") does not seem to work at all. When you flip any toggle, the toggle will be reset to its original position the next time you open the tool.


Version-Release number of selected component (if applicable): abrt 2.1.6-2.fc19


How reproducible: Always


Steps to Reproduce:
1. Launch system-config-abrt and change any of the four toggle settings.
2. Close and reopen.

Actual results: The setting has reset to its original value.


Expected results: The setting retains its set value.
Comment 1 Jakub Filak 2013-08-07 11:21:48 EDT
Thank you for the bug report. When I flip any toggle, click Apply button, close, reopen, the setting retains its set value. If this doesn't work for you, please check access rights to you configuration files stored in ~/.config/abrt/settings/
Comment 2 Michael Catanzaro 2013-08-07 17:25:09 EDT
(In reply to Jakub Filak from comment #1)
> Thank you for the bug report. When I flip any toggle, click Apply button,
> close, reopen, the setting retains its set value. If this doesn't work for
> you, please check access rights to you configuration files stored in
> ~/.config/abrt/settings/

From ~/.config/abrt/settings:

[mcatanzaro@victory-road settings]$ ls -alZ
drwx------. mcatanzaro mcatanzaro unconfined_u:object_r:config_home_t:s0 .
drwxrwxr-x. mcatanzaro mcatanzaro unconfined_u:object_r:config_home_t:s0 ..
-rw-rw-r--. mcatanzaro mcatanzaro unconfined_u:object_r:config_home_t:s0 abrt-applet.conf
-rw-rw-r--. mcatanzaro mcatanzaro unconfined_u:object_r:config_home_t:s0 report-gtk.conf

Which all looks fine to me.

When I run system-config-abrt from a terminal with the environment variable G_MESSAGES_DEBUG=all, there are unfortunately no warnings.
Comment 3 Michael Catanzaro 2013-08-08 11:20:49 EDT
Jakub figured out the problem: I couldn't see the "Apply" button on the bottom of the screen due to Bug #993592

*** This bug has been marked as a duplicate of bug 993592 ***

Note You need to log in before you can comment on or make changes to this bug.