Bug 996176 - [RFE] Add a hostgroup to Foreman for a deploying an OpenStack Controller node with cinder.
[RFE] Add a hostgroup to Foreman for a deploying an OpenStack Controller node...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer (Show other bugs)
3.0
Unspecified Linux
high Severity high
: beta
: 4.0
Assigned To: Jiri Stransky
Omri Hochman
: FutureFeature, TestOnly
: 1027001 (view as bug list)
Depends On: 1010307
Blocks: RHOS40RFE 1010310 1027001 1045056
  Show dependency treegraph
 
Reported: 2013-08-12 11:04 EDT by Omri Hochman
Modified: 2013-12-19 19:19 EST (History)
10 users (show)

See Also:
Fixed In Version: openstack-foreman-installer-0.0.20-1.el6ost
Doc Type: Enhancement
Doc Text:
Feature: Add block storage (Cinder) support. Reason: Previously we did not install Cinder with Foreman. Result (if any): * Cinder API has been added to the Controller hostgroups (both "Controller (Neutron)" and "Controller (Nova Network)". * Cinder storage (where block storage data is stored) has a separate host group "LVM Block Storage", so that the storage capacity is scalable. This host group can be deployed only on hosts where "cinder-volumes" LVM volume group exists.
Story Points: ---
Clone Of:
: 1027001 1045056 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:19:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Omri Hochman 2013-08-12 11:04:15 EDT
[RFE] Add a hostgroup to Foreman for a deploying an OpenStack Controller node with cinder.

The requirement is pretty much the same as in Bug #970283 - Currently clients of the 'controller HostGroup ' will be installed with : Nova, keystone, glance, horizon - But without Cinder. 

We need to add cinder installation to the exist 'controller' hostGroup, or to add dedicated hostsGroup for a deploying an OpenStack Controller node with cinder.
Comment 1 Jiri Stransky 2013-09-27 10:47:24 EDT
Upstream code submitted and merged:
https://github.com/redhat-openstack/astapor/pull/12

Upstream docs on RDO wiki:
http://openstack.redhat.com/Deploying_RDO_Using_Foreman#Cinder_Storage_Nodes
Comment 3 Jason Guiditta 2013-11-05 15:59:45 EST
Is this really meant to be rhos 3.0?  I am pretty sure this code was built only with rhos 4/havana in mind
Comment 4 Jiri Stransky 2013-11-11 08:20:47 EST
(In reply to Jason Guiditta from comment #3)
> Is this really meant to be rhos 3.0?  I am pretty sure this code was built
> only with rhos 4/havana in mind

That's right, it was built on Havana.
Comment 6 Scott Lewis 2013-11-27 07:52:28 EST
*** Bug 1027001 has been marked as a duplicate of this bug. ***
Comment 11 errata-xmlrpc 2013-12-19 19:19:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.